BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW M2 Forum > Regional Forums > AUSTRALIA > Auto engine stop

Post Reply
 
Thread Tools Search this Thread
      07-13-2018, 05:15 AM   #1
lockwood
New Member
1
Rep
16
Posts

Drives: m2 lci
Join Date: Jun 2018
Location: canberra

iTrader: (0)

Auto engine stop

Does anyone know if the 'auto engine stop' can be set as a default to be 'off' when you turn the ignition on, rather than 'on' through the BMW dealer? Has anyone had it done?
Appreciate 0
      07-13-2018, 05:32 AM   #2
DrKevM5
Colonel
DrKevM5's Avatar
United_States
1656
Rep
2,205
Posts

Drives: G05 X5, F87 M2
Join Date: Aug 2008
Location: Western NY

iTrader: (7)

It can be done through coding
__________________
'16 M2 Long Beach Blue/Black, 6MT
'19 X5 4.0 M Sport Black Sapphire/Tartufo
'18 Alfa Romeo Stelvio Quadrifoglio Vesuvio Grey/Black
Appreciate 0
      07-13-2018, 06:13 AM   #3
tayyq
Registered
0
Rep
3
Posts

Drives: F22
Join Date: May 2018
Location: SG/AU

iTrader: (0)

I used BimmerCode with a Bluetooth adapter. Easily done.
Appreciate 0
      07-13-2018, 06:38 AM   #4
lockwood
New Member
1
Rep
16
Posts

Drives: m2 lci
Join Date: Jun 2018
Location: canberra

iTrader: (0)

My dealer told me that it could be reset in early M2ís but not the later versions, mine is a 2017 LCI
Appreciate 0
      07-13-2018, 06:58 AM   #5
AndrewC1989
Brigadier General
AndrewC1989's Avatar
United_States
7250
Rep
3,092
Posts

Drives: 2017 M2 | 2015 328dx
Join Date: Aug 2010
Location: New Jersey

iTrader: (5)

Garage List
2017 M2  [5.00]
2015 328d xDrive  [0.00]
Quote:
Originally Posted by lockwood View Post
My dealer told me that it could be reset in early M2ís but not the later versions, mine is a 2017 LCI
No such thing as a '17 LCI. MY18 was the first and only year for it. Even if your car was produced in mid-late 2017 it's still a 2018 technically.
Appreciate 0
      07-13-2018, 10:17 AM   #6
nioh_lbbm2
Major
nioh_lbbm2's Avatar
821
Rep
1,228
Posts

Drives: '18 M2 6MT
Join Date: Mar 2018
Location: California

iTrader: (0)

I have the LCI and it stays on whatever you set it to last. No coding needed.
Appreciate 0
      07-14-2018, 01:20 AM   #7
Zuzu
Major General
Zuzu's Avatar
Australia
239
Rep
7,445
Posts

Drives: LBB LCI M2
Join Date: Mar 2008
Location: Sydney Australia

iTrader: (0)

Quote:
Originally Posted by nioh_lbbm2 View Post
I have the LCI and it stays on whatever you set it to last. No coding needed.
Really.. thats odd, as I also have the LCI and this is not the case..

Have spoke to dealer and was told nothing can be done about leaving on last setting.

So like others, I have just coded off.. Perfect.
Appreciate 0
      07-14-2018, 08:24 AM   #8
nioh_lbbm2
Major
nioh_lbbm2's Avatar
821
Rep
1,228
Posts

Drives: '18 M2 6MT
Join Date: Mar 2018
Location: California

iTrader: (0)

Quote:
Originally Posted by Zuzu View Post
Quote:
Originally Posted by nioh_lbbm2 View Post
I have the LCI and it stays on whatever you set it to last. No coding needed.
Really.. thats odd, as I also have the LCI and this is not the case..

Have spoke to dealer and was told nothing can be done about leaving on last setting.

So like others, I have just coded off.. Perfect.
It's supposed to remember the last setting. See use manual info:
Attached Images
 
Appreciate 0
      07-14-2018, 10:01 AM   #9
atlas
Second Lieutenant
Australia
87
Rep
259
Posts

Drives: F10 535i, M2 LCI, G05 X5 40i
Join Date: Nov 2009
Location: Melbourne, Australia

iTrader: (0)

Quote:
Originally Posted by nioh_lbbm2 View Post
I have the LCI and it stays on whatever you set it to last. No coding needed.
Really? Even when the car is completely switched off?
Appreciate 0
      07-14-2018, 10:14 AM   #10
Who?
Colonel
Who?'s Avatar
Australia
448
Rep
2,207
Posts

Drives: F87 LCI
Join Date: Nov 2012
Location: Brisbane

iTrader: (0)

Yeah I have an Lce, and it didn’t remember the last setting when I turned ignition off

So I coded it via bimmercode
__________________
So far: 200cell downpipe, custom exhaust, lifhtweight splitter, m4 comp seats
Appreciate 0
      07-14-2018, 10:32 AM   #11
nioh_lbbm2
Major
nioh_lbbm2's Avatar
821
Rep
1,228
Posts

Drives: '18 M2 6MT
Join Date: Mar 2018
Location: California

iTrader: (0)

Quote:
Originally Posted by atlas View Post
Really? Even when the car is completely switched off?
yes. it remembers the last setting it was set to no matter what. It's supposed to and is even stated as such in the owner's manual
Appreciate 0
      07-14-2018, 10:36 AM   #12
randyt
Second Lieutenant
randyt's Avatar
United_States
217
Rep
238
Posts

Drives: 2018 MGM 6MT M2
Join Date: Apr 2013
Location: Rockville, Maryland

iTrader: (0)

Garage List
2018 BMW M2  [0.00]
Quote:
Originally Posted by nioh_lbbm2 View Post
Quote:
Originally Posted by atlas View Post
Really? Even when the car is completely switched off?
yes. it remembers the last setting it was set to no matter what. It's supposed to and is even stated as such in the owner's manual
Same here. My '18 LCI remembers the last setting.
Appreciate 0
      07-14-2018, 07:59 PM   #13
Who?
Colonel
Who?'s Avatar
Australia
448
Rep
2,207
Posts

Drives: F87 LCI
Join Date: Nov 2012
Location: Brisbane

iTrader: (0)

That’s bizarre, mine was never like that, and when the dealer updated the software, it reverted back to On at start.. so I had to code it back..
__________________
So far: 200cell downpipe, custom exhaust, lifhtweight splitter, m4 comp seats
Appreciate 0
      07-15-2018, 07:41 PM   #14
dcmac
Lieutenant
dcmac's Avatar
383
Rep
433
Posts

Drives: '18 LCI M2
Join Date: Nov 2016
Location: Denver, CO

iTrader: (0)

I have Ď18 LCI and it remembers last setting.. I turned it off and it stays off. Maybe its a DCT v MT thing? (Iím MT)
Appreciate 0
      07-21-2018, 10:32 PM   #15
kab_m2
Second Lieutenant
kab_m2's Avatar
Australia
110
Rep
252
Posts

Drives: M135i, X1 25i, M2 LCI
Join Date: Jan 2013
Location: Melbourne, Australia

iTrader: (0)

LCI here too and I have to turn it off every time
Appreciate 0
      07-22-2018, 12:50 AM   #16
Who?
Colonel
Who?'s Avatar
Australia
448
Rep
2,207
Posts

Drives: F87 LCI
Join Date: Nov 2012
Location: Brisbane

iTrader: (0)

Quote:
Originally Posted by kab_m2 View Post
LCI here too and I have to turn it off every time
should get bimmercode (or find someone local that has it and buy him a coffee lol)
__________________
So far: 200cell downpipe, custom exhaust, lifhtweight splitter, m4 comp seats
Appreciate 0
      07-22-2018, 09:48 AM   #17
randyt
Second Lieutenant
randyt's Avatar
United_States
217
Rep
238
Posts

Drives: 2018 MGM 6MT M2
Join Date: Apr 2013
Location: Rockville, Maryland

iTrader: (0)

Garage List
2018 BMW M2  [0.00]
Quote:
Originally Posted by dcmac View Post
I have '18 LCI and it remembers last setting.. I turned it off and it stays off. Maybe its a DCT v MT thing? (I'm MT)
Good point, my '18 LCI is MT as well. According to the manual, it should retain the setting. No mention of DCT vs MT.

Last edited by randyt; 07-22-2018 at 10:02 AM..
Appreciate 0
      07-22-2018, 10:02 AM   #18
David.m
Second Lieutenant
133
Rep
238
Posts

Drives: M2 LCI 6MT BSM
Join Date: Aug 2016
Location: Australia

iTrader: (0)

Quote:
Originally Posted by dcmac View Post
I have Ď18 LCI and it remembers last setting.. I turned it off and it stays off. Maybe its a DCT v MT thing? (Iím MT)
Quote:
Originally Posted by randyt View Post
Good point, my '18 LCI is MT as well.
It's a region based thing, Australian delivered cars all default to 'on' each time you start the car whereas you lucky US cars get 'remember last setting'. Why I don't know but it is easily fixed with bimmercode
Appreciate 3
randyt217.00
TheHaze49.50
dcmac383.00

      07-22-2018, 10:13 AM   #19
Ceridan
New Member
Ceridan's Avatar
Canada
23
Rep
29
Posts

Drives: 2018 M2 LCI
Join Date: May 2012
Location: Victoria, BC

iTrader: (0)

Garage List
2008 BMW M6  [0.00]
2018 BMW M2  [0.00]
Quote:
Originally Posted by David.m View Post
It's a region based thing, Australian delivered cars all default to 'on' each time you start the car whereas you lucky US cars get 'remember last setting'. Why I don't know but it is easily fixed with bimmercode
Canadian '18 LCI here, mine remembers last setting as well. I thought about trying to code it to 'always off' but due to my commute I actually end up using it a fair bit, so it works quite well as is.
__________________
2018 M2 LCI - Living the Dream!
2008 M6 Manual - In Storage
Appreciate 0
      07-23-2018, 04:12 PM   #20
dcmac
Lieutenant
dcmac's Avatar
383
Rep
433
Posts

Drives: '18 LCI M2
Join Date: Nov 2016
Location: Denver, CO

iTrader: (0)

Quote:
Originally Posted by David.m View Post
It's a region based thing, Australian delivered cars all default to 'on' each time you start the car whereas you lucky US cars get 'remember last setting'. Why I don't know but it is easily fixed with bimmercode
Ah, right. Us poor Aussies... from over zealous cops and speed cameras to outrageous car prices, it's tough to be a car lover back home. I had to move to the USA to even afford an M2
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 11:52 PM.




m2
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST