BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
M2 Technical Topics > Cosmetic Modifications > LED Bulb swap for NON-LCI Tails

Post Reply
 
Thread Tools Search this Thread
      07-23-2017, 04:24 PM   #1
ChrisK
Major General
ChrisK's Avatar
United_States
3750
Rep
7,290
Posts

Drives: '19 M2C
Join Date: Jun 2007
Location: Chicagoland (West)

iTrader: (7)

Garage List
LED Bulb swap for NON-LCI Tails

I really like some of the LCI changes, but I really like the non-LCI tails. However I am totally frustrated with BMW and the absence of LED's on a 2017. That's whole another discussion!

I decided to swap my incandescent #1156 bulbs for SiriusLED replacements. I have been using the replacement LED's on the front of the car for the turn signals for awhile now and they perform perfectly.

See this thread for the front turn signals: http://f87.bimmerpost.com/forums/sho...&highlight=LED

Here are some videos and images. The LED's look great, and are much brighter. I have the bulb check coded out, so I do not see and flicker of course.

There are a total of 10 bulbs that need to be swapped in each rear tail assembly.

Here is what you need:

8 x SiriusLED # 1156 (Red) - Used for the brake lights (x6) and the Turn signals (x2)
2 x SiriusLED # 1156 (White) - Used for the reverse lights (x2)

Link to purchase the LED's: https://www.amazon.com/gp/product/B0..._st_dp_summary




See above - LED is installed on the right side for comparison.



See above - LED's are installed in both reverse bulb sockets.



See above - LED's are installed in both turn signal sockets.



See above - LED installed in turn signal socket. Close-up
Attached Images
    
__________________
www.ReTuneTheDeTune.com
2019 M2 Competition (Sunset Orange)

Last edited by ChrisK; 07-23-2017 at 05:05 PM..
Appreciate 13
      07-23-2017, 04:59 PM   #2
MerlinPurple
Second Lieutenant
MerlinPurple's Avatar
United_States
674
Rep
290
Posts

Drives: M2 LBB
Join Date: Jul 2016
Location: GB

iTrader: (0)

Awesome thread, thank you for the info - looks great
__________________
Appreciate 0
      07-28-2017, 08:18 AM   #3
McGary911
Finally!
McGary911's Avatar
United_States
396
Rep
620
Posts

Drives: 2017 LBB M2 DCT
Join Date: Jan 2017
Location: St Johns, FL

iTrader: (0)

I keep coming back to this thread. I'm thinking I really like this.

When I was searching for my E46 M3, I made sure to start looking @ 2004 as that's when they added LED tails to those cars (yeah, actually 2003.5, I know).

So this looks like a $100 update more or less? If you don't code out the bulb check do you get a warning i take it? I have bimmercode. Would you know what to actually code out using that?

And what the heck does that rear fog do beyond the emergency brake thing? AFIK this car doesn't have any fog lights? Do the rears ever come on outside of braking? I may ask that on another thread.
__________________
2004 E46 ///M3 SMG Convertible Carbon Blk\Imola
2017 LBB ///M2 DCT
Appreciate 0
      07-28-2017, 09:04 AM   #4
ChrisK
Major General
ChrisK's Avatar
United_States
3750
Rep
7,290
Posts

Drives: '19 M2C
Join Date: Jun 2007
Location: Chicagoland (West)

iTrader: (7)

Garage List
Quote:
Originally Posted by McGary911 View Post
I keep coming back to this thread. I'm thinking I really like this.

When I was searching for my E46 M3, I made sure to start looking @ 2004 as that's when they added LED tails to those cars (yeah, actually 2003.5, I know).

So this looks like a $100 update more or less? If you don't code out the bulb check do you get a warning i take it? I have bimmercode. Would you know what to actually code out using that?

And what the heck does that rear fog do beyond the emergency brake thing? AFIK this car doesn't have any fog lights? Do the rears ever come on outside of braking? I may ask that on another thread.
  • On Amazon I spent $114 for the rear LED replacements.
  • I used bimmercode to change the rear bulb setting to "LED" - and you are good to go. No errors, no flashing. I coded them to LED before I did the swap, so I have no idea what error(s) will come up with the LEDs without coding.
  • Besides the emergency brake and rear fog - it does nothing as far I am aware.
__________________
www.ReTuneTheDeTune.com
2019 M2 Competition (Sunset Orange)
Appreciate 1
      07-28-2017, 12:45 PM   #5
McGary911
Finally!
McGary911's Avatar
United_States
396
Rep
620
Posts

Drives: 2017 LBB M2 DCT
Join Date: Jan 2017
Location: St Johns, FL

iTrader: (0)

I just ordered the LEDs and they'll be here Tuesday, apparently.

Do you have the bimmercode values that have to be updated?

i also found a thread on getting the fogs to work. The switch needs to be added and of course, more coding. I may give that a shot as well.

http://f30.bimmerpost.com/forums/sho...d.php?t=877278

Thanks......
__________________
2004 E46 ///M3 SMG Convertible Carbon Blk\Imola
2017 LBB ///M2 DCT
Appreciate 0
      07-28-2017, 01:03 PM   #6
ChrisK
Major General
ChrisK's Avatar
United_States
3750
Rep
7,290
Posts

Drives: '19 M2C
Join Date: Jun 2007
Location: Chicagoland (West)

iTrader: (7)

Garage List
Quote:
Originally Posted by McGary911 View Post
I just ordered the LEDs and they'll be here Tuesday, apparently.

Do you have the bimmercode values that have to be updated?

i also found a thread on getting the fogs to work. The switch needs to be added and of course, more coding. I may give that a shot as well.

http://f30.bimmerpost.com/forums/sho...d.php?t=877278

Thanks......
Try these:

Rear Electronic Module > Reversing light left lamp > LED
Rear Electronic Module > Reversing right left lamp > LED
Rear Electronic Module > Tail light lamp > LED
Rear Electronic Module > Tail light inner lamp > LED
Rear Electronic Module > Brake light lamp > LED

I think the "monitoring" of each light needs to be set "Not Active".
__________________
www.ReTuneTheDeTune.com
2019 M2 Competition (Sunset Orange)
Appreciate 1
McGary911396.00

      07-28-2017, 01:19 PM   #7
McGary911
Finally!
McGary911's Avatar
United_States
396
Rep
620
Posts

Drives: 2017 LBB M2 DCT
Join Date: Jan 2017
Location: St Johns, FL

iTrader: (0)

Quote:
Originally Posted by ChrisK View Post
Try these:

Rear Electronic Module > Reversing light left lamp > LED
Rear Electronic Module > Reversing right left lamp > LED
Rear Electronic Module > Tail light lamp > LED
Rear Electronic Module > Tail light inner lamp > LED
Rear Electronic Module > Brake light lamp > LED

I think the "monitoring" of each light needs to be set "Not Active".
thanks. I'll give it a shot when my LEDs get here on Tuesday....and let everyone know how it goes.
__________________
2004 E46 ///M3 SMG Convertible Carbon Blk\Imola
2017 LBB ///M2 DCT
Appreciate 0
      08-01-2017, 08:42 PM   #8
McGary911
Finally!
McGary911's Avatar
United_States
396
Rep
620
Posts

Drives: 2017 LBB M2 DCT
Join Date: Jan 2017
Location: St Johns, FL

iTrader: (0)

Thumbs up

Well, this worked great.

4 nuts, 10 lamp replacements, 3 minutes of coding and I have my LED tails.

I changed one additional coding, an indicator one to LED. Pretty much everything that said bulb is now saying LED, except for the rear fogs, which now work thanks to the other mod I noted above.

With bimmercode, I didn't even have to get into advanced.

I coded the car with the lights disconnected and got a warning. That went away when I hooked everything back up.

It's so nice when things work the first time.

Thanks again on doing the homework for the lamps and the coding.

If anyone is on the fence, do it up. It's too cheap and easy not to.



Here's a question. When you separate the lens from the housing, there's a ground plug that disconnects between the two. Any idea what that's for? There's no power running that way, so what's the ground for. That had me scratching my head.
__________________
2004 E46 ///M3 SMG Convertible Carbon Blk\Imola
2017 LBB ///M2 DCT
Appreciate 1
      08-01-2017, 11:49 PM   #9
LA_M2
Private
14
Rep
51
Posts

Drives: Black M2
Join Date: Apr 2017
Location: Los Angeles

iTrader: (0)

Thanks ChrisK ! I did mine today and it worked out great.
Appreciate 0
      08-02-2017, 03:34 PM   #10
ChrisK
Major General
ChrisK's Avatar
United_States
3750
Rep
7,290
Posts

Drives: '19 M2C
Join Date: Jun 2007
Location: Chicagoland (West)

iTrader: (7)

Garage List
Enjoy!
__________________
www.ReTuneTheDeTune.com
2019 M2 Competition (Sunset Orange)
Appreciate 0
      08-02-2017, 06:22 PM   #11
MJCRO
New Member
United_States
24
Rep
27
Posts

Drives: 2017 BMW M2 LBB/6MT
Join Date: Aug 2016
Location: Mamaroneck, NY

iTrader: (0)

Wow, this looks great and great feedback ChrisK.

So once coded, any flicker and start up light tests are removed? What coding app do you guys recommend?
Appreciate 0
      08-02-2017, 07:38 PM   #12
McGary911
Finally!
McGary911's Avatar
United_States
396
Rep
620
Posts

Drives: 2017 LBB M2 DCT
Join Date: Jan 2017
Location: St Johns, FL

iTrader: (0)

Quote:
Originally Posted by MJCRO View Post
Wow, this looks great and great feedback ChrisK.

So once coded, any flicker and start up light tests are removed? What coding app do you guys recommend?
Zero flicker and zero engine light. The only reason i got the latter was because I coded it with the tails sitting in my kitchen. I can't say I was surprised. I hooked them back up and all was well.

I use Bimmercode which is only available for apple devices. It needs an OBDII dongle which costs about $20 and to activate the software is another $29. I used credits in the apple store and it only cost me $4. Check the stereo forum on this M2 board for more details on that. There are a LOT of pages on that thread.
__________________
2004 E46 ///M3 SMG Convertible Carbon Blk\Imola
2017 LBB ///M2 DCT
Appreciate 1
      08-02-2017, 09:39 PM   #13
DoggieHowser
First Lieutenant
201
Rep
361
Posts

Drives: F87 Pure F20 125i MSport 2017
Join Date: Apr 2017
Location: Australia

iTrader: (0)

Never understood why BMW fitted LED lights for the tail lights but still used regular bulbs for signals and brakes

I wonder if anyone in Brisbane can do this
Appreciate 0
      08-04-2017, 07:53 AM   #14
ChrisK
Major General
ChrisK's Avatar
United_States
3750
Rep
7,290
Posts

Drives: '19 M2C
Join Date: Jun 2007
Location: Chicagoland (West)

iTrader: (7)

Garage List
Quote:
Originally Posted by DoggieHowser View Post
Never understood why BMW fitted LED lights for the tail lights but still used regular bulbs for signals and brakes

I wonder if anyone in Brisbane can do this
I am tired of BMW doing this LCI led crap. Same thing they did with the e92 M3. Etc etc. just use LED?s out of the gate.
__________________
www.ReTuneTheDeTune.com
2019 M2 Competition (Sunset Orange)
Appreciate 0
      08-04-2017, 08:37 AM   #15
AGM2
Lieutenant
AGM2's Avatar
United_States
285
Rep
499
Posts

Drives: M2 LBB 17
Join Date: Jul 2016
Location: Land O Lakes FL

iTrader: (0)

Great Info Thank you !!!
Appreciate 0
      08-04-2017, 11:35 PM   #16
MJCRO
New Member
United_States
24
Rep
27
Posts

Drives: 2017 BMW M2 LBB/6MT
Join Date: Aug 2016
Location: Mamaroneck, NY

iTrader: (0)

Got my LEDs today (ordered double by accident, didn't realize it was a set for each lol).

VERY pleased! The tailights and front turn signals now look proper for the pre-LCI M2. The deep redness of the red LEDs for the brake and rear turn signal look MUCH better than the incandescents. I feel like the reverse LED is a bit on the bright side (but it does remind me of new Mercedes' reverse light LEDs, which are also very bright from what I've witnessed).

Overall a 10/10 DYI mod. Definitely worth the $100 in LEDs. Will post pictures and a video tomorrow.
Appreciate 0
      08-07-2017, 11:52 AM   #17
ChrisK
Major General
ChrisK's Avatar
United_States
3750
Rep
7,290
Posts

Drives: '19 M2C
Join Date: Jun 2007
Location: Chicagoland (West)

iTrader: (7)

Garage List
Quote:
Originally Posted by MJCRO View Post
Got my LEDs today (ordered double by accident, didn't realize it was a set for each lol).

VERY pleased! The tailights and front turn signals now look proper for the pre-LCI M2. The deep redness of the red LEDs for the brake and rear turn signal look MUCH better than the incandescents. I feel like the reverse LED is a bit on the bright side (but it does remind me of new Mercedes' reverse light LEDs, which are also very bright from what I've witnessed).

Overall a 10/10 DYI mod. Definitely worth the $100 in LEDs. Will post pictures and a video tomorrow.
Agree completely. I tried the white LED's for the brakes, but the color didn't look right. It was many times brighter then stock - didnt like that either. Red LED's do provide the deep redness.

The reverse LED's being brighter - fine by me
__________________
www.ReTuneTheDeTune.com
2019 M2 Competition (Sunset Orange)
Appreciate 0
      08-10-2017, 10:46 AM   #18
riko///m2
New Member
riko///m2's Avatar
United_States
2
Rep
6
Posts

Drives: LSB E46 M3 and 25 yo red car
Join Date: Apr 2016
Location: San Francisco

iTrader: (0)

I upgraded my '17 M2 tail lights to LED's too.

I used 4 pairs of Philips 1156 Bright White Vision Led ($21/pair) and one pair of cheap 1156 LED's for the reverse light ($9).

I went cheap on the reverse light as I figure the reverse lights are not so important.

I was surprised that I do not have to code to disable the bulb check.

They are great.
__________________
A white Honda minivan, a white Honda Civic X, a blue BMW M3(e46), a white BMW M2, and a 25 year old red car.

Last edited by riko///m2; 08-12-2017 at 07:48 PM..
Appreciate 1
KGun52.50

      08-10-2017, 04:49 PM   #19
MJCRO
New Member
United_States
24
Rep
27
Posts

Drives: 2017 BMW M2 LBB/6MT
Join Date: Aug 2016
Location: Mamaroneck, NY

iTrader: (0)

Quote:
Originally Posted by ChrisK View Post
Agree completely. I tried the white LED's for the brakes, but the color didn't look right. It was many times brighter then stock - didnt like that either. Red LED's do provide the deep redness.

The reverse LED's being brighter - fine by me
So far been running them the last couple of days without any issue. I just got my Carly adapter yesterday, but surprisingly I haven't got any codes or flicker or light tests going on with these LEDs since I installed them. Is the light test only being done by the ECU while in motion? Had the car parked and all the lights switched on and didn't see anything after 10-15 minutes of waiting.
Appreciate 0
      08-15-2017, 08:02 PM   #20
Midn1ght
Enlisted Member
35
Rep
33
Posts

Drives: BMW M2
Join Date: Nov 2016
Location: Chicago

iTrader: (0)

Hey guys/gals. I went ahead and made the change today and it looks outstanding. I'm waiting for my wifi dongle to do the coding.

On start up I do get two error messages. They are right and left taillights as expected.

For anyone else doing this retrofit, the tool in the toolkit really doesn't do the job of removing the fasteners. It's a 10mm and I used a ratchet with an extension.
Appreciate 0
      08-16-2017, 12:01 PM   #21
MJCRO
New Member
United_States
24
Rep
27
Posts

Drives: 2017 BMW M2 LBB/6MT
Join Date: Aug 2016
Location: Mamaroneck, NY

iTrader: (0)

Quote:
Originally Posted by Midn1ght View Post
Hey guys/gals. I went ahead and made the change today and it looks outstanding. I'm waiting for my wifi dongle to do the coding.

On start up I do get two error messages. They are right and left taillights as expected.

For anyone else doing this retrofit, the tool in the toolkit really doesn't do the job of removing the fasteners. It's a 10mm and I used a ratchet with an extension.
Weird, I don't get any errors. I'm using Carly for my coding. Interesting thing is when I went in there to code out the voltage monitoring, the errors actually showed up, so I went back to the factory settings.
Appreciate 0
      08-16-2017, 01:16 PM   #22
Midn1ght
Enlisted Member
35
Rep
33
Posts

Drives: BMW M2
Join Date: Nov 2016
Location: Chicago

iTrader: (0)

Quote:
Originally Posted by MJCRO View Post
Quote:
Originally Posted by Midn1ght View Post
Hey guys/gals. I went ahead and made the change today and it looks outstanding. I'm waiting for my wifi dongle to do the coding.

On start up I do get two error messages. They are right and left taillights as expected.

For anyone else doing this retrofit, the tool in the toolkit really doesn't do the job of removing the fasteners. It's a 10mm and I used a ratchet with an extension.
Weird, I don't get any errors. I'm using Carly for my coding. Interesting thing is when I went in there to code out the voltage monitoring, the errors actually showed up, so I went back to the factory settings.
I get the error upon startup. I have not done any coding yet.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 10:47 AM.




m2
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST