BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW M2 Forum > BMW M2 Competition Model > How Do You Make Apple Car Play Come On At Start Up

Post Reply
 
Thread Tools Search this Thread
      11-22-2019, 02:04 PM   #1
5150d
Enlisted Member
50
Rep
49
Posts

Drives: BMW M2 Competition
Join Date: Apr 2019
Location: USA

iTrader: (0)

How Do You Make Apple Car Play Come On At Start Up

2020 M2 Competition. Apple Car Play works but I have to push a saved button to get to it. The idrive navagation comes on at start up and just sometimes Car Play starts. How do I make the Apple Car Play come on at start up everytime?
Thanks!
Appreciate 0
      11-22-2019, 02:35 PM   #2
Detoxified
Private
33
Rep
76
Posts

Drives: M2C HS
Join Date: Jun 2019
Location: SoCal

iTrader: (0)

Mine auto pop ups within 5-10seconds? Odd
Appreciate 0
      11-22-2019, 05:23 PM   #3
nioh_lbbm2
Captain
542
Rep
894
Posts

Drives: '18 M2 6MT
Join Date: Mar 2018
Location: California

iTrader: (0)

Make sure you have CarPlay enabled on your iPhone.

Settings - General - CarPlay - (your car) - set the CarPlay slider to "on"

This is the setting that launches CarPlay upon connecting to your car
Appreciate 0
      11-24-2019, 02:12 PM   #4
5150d
Enlisted Member
50
Rep
49
Posts

Drives: BMW M2 Competition
Join Date: Apr 2019
Location: USA

iTrader: (0)

Quote:
Originally Posted by nioh_lbbm2 View Post
Make sure you have CarPlay enabled on your iPhone.

Settings - General - CarPlay - (your car) - set the CarPlay slider to "on"

This is the setting that launches CarPlay upon connecting to your car
I do - but most of the time the BMW idrive navigation comes on at start up. I called the Genius line but they were no help.
Appreciate 0
      11-24-2019, 02:15 PM   #5
nioh_lbbm2
Captain
542
Rep
894
Posts

Drives: '18 M2 6MT
Join Date: Mar 2018
Location: California

iTrader: (0)

Quote:
Originally Posted by 5150d View Post
Quote:
Originally Posted by nioh_lbbm2 View Post
Make sure you have CarPlay enabled on your iPhone.

Settings - General - CarPlay - (your car) - set the CarPlay slider to "on"

This is the setting that launches CarPlay upon connecting to your car
I do - but most of the time the BMW idrive navigation comes on at start up. I called the Genius line but they were no help.
Do you have regular appointments in your calendar app with destinations on them?

If so check your Connected drive app and make sure it is set to NOT automatically send the designation to your car. This launches BMW Navi automatically
Appreciate 0
      11-24-2019, 04:07 PM   #6
5150d
Enlisted Member
50
Rep
49
Posts

Drives: BMW M2 Competition
Join Date: Apr 2019
Location: USA

iTrader: (0)

Quote:
Originally Posted by nioh_lbbm2 View Post
Do you have regular appointments in your calendar app with destinations on them?

If so check your Connected drive app and make sure it is set to NOT automatically send the designation to your car. This launches BMW Navi automatically
My app on the iPhone does show as a feature in the vehicle Send Destination to Vehicle. How do I turn it off?
Under Activity "import calendars & get alerts" is not enabled but don't know if this is the same?
Under Calendars in settings shows not enabled but don't know if this is the same?

BUT....I did see that there is a toggle under MORE -> SETTINGS to "Auto Start Navigation".
Maybe this is the issue......

Last edited by 5150d; 11-24-2019 at 04:19 PM..
Appreciate 0
      11-24-2019, 08:40 PM   #7
nioh_lbbm2
Captain
542
Rep
894
Posts

Drives: '18 M2 6MT
Join Date: Mar 2018
Location: California

iTrader: (0)

Quote:
Originally Posted by 5150d View Post
Quote:
Originally Posted by nioh_lbbm2 View Post
Do you have regular appointments in your calendar app with destinations on them?

If so check your Connected drive app and make sure it is set to NOT automatically send the designation to your car. This launches BMW Navi automatically
My app on the iPhone does show as a feature in the vehicle Send Destination to Vehicle. How do I turn it off?
Under Activity "import calendars & get alerts" is not enabled but don't know if this is the same?
Under Calendars in settings shows not enabled but don't know if this is the same?

BUT....I did see that there is a toggle under MORE -> SETTINGS to "Auto Start Navigation".
Maybe this is the issue......
I believe that is the one
Appreciate 0
      11-25-2019, 12:01 PM   #8
5150d
Enlisted Member
50
Rep
49
Posts

Drives: BMW M2 Competition
Join Date: Apr 2019
Location: USA

iTrader: (0)

Quote:
Originally Posted by nioh_lbbm2 View Post
I believe that is the one
Turning off this did not help. Car Play still does not come on at start up.

I contacted BMW Genius and here is their response:

"Apple Carplay is a secondary environment that operates on the idrive system. Carplay cannot load to the vehicle before the vehicle's native system has loaded."

Does anyone here have CarPlay and does it load at startup?
Appreciate 0
      11-25-2019, 12:03 PM   #9
nioh_lbbm2
Captain
542
Rep
894
Posts

Drives: '18 M2 6MT
Join Date: Mar 2018
Location: California

iTrader: (0)

Not sure then. My CarPlay loads up upon connecting to iDrive immediately.
Appreciate 0
      11-25-2019, 01:15 PM   #10
andrewc89
Colonel
andrewc89's Avatar
United_States
6706
Rep
2,902
Posts

Drives: 2017 M2 | 2015 328dx
Join Date: Aug 2010
Location: New Jersey

iTrader: (5)

Garage List
2017 M2  [5.00]
2015 328d xDrive  [0.00]
Quote:
Originally Posted by 5150d View Post
Does anyone here have CarPlay and does it load at startup?
This is how it works in my car:

I hit start/stop, the M logo startup screen appears, the home screen for iDrive is then shown, I wait 5 seconds and the apple car play logo appears in the bottom left, I wait another 5 seconds and it automatically switches over to the apple car play home screen.

My guess is that your car would do this too but you probably aren't being patient enough and giving it the time it needs to load up.
Appreciate 1
bmwm2nyc225.00

      11-26-2019, 10:47 AM   #11
Habber
Captain
Canada
846
Rep
948
Posts

Drives: BMW M3 2018
Join Date: Sep 2016
Location: Montreal

iTrader: (1)

I had similar issue but now it seems to pop up within 10 seconds of startup.
Appreciate 0
      11-29-2019, 01:27 PM   #12
5150d
Enlisted Member
50
Rep
49
Posts

Drives: BMW M2 Competition
Join Date: Apr 2019
Location: USA

iTrader: (0)

Quote:
Originally Posted by andrewc89 View Post
This is how it works in my car:

I hit start/stop, the M logo startup screen appears, the home screen for iDrive is then shown, I wait 5 seconds and the apple car play logo appears in the bottom left, I wait another 5 seconds and it automatically switches over to the apple car play home screen.

My guess is that your car would do this too but you probably aren't being patient enough and giving it the time it needs to load up.
Wish that worked for me but it does not.
Any advice?
Appreciate 0
      11-29-2019, 02:19 PM   #13
KevinM
Colonel
KevinM's Avatar
2101
Rep
2,898
Posts

Drives: 2002 M5;2007 M Coupe;2020 M2C
Join Date: Jul 2011
Location: Tucson

iTrader: (0)

Garage List
Quote:
Originally Posted by 5150d View Post
Wish that worked for me but it does not.
Any advice?
Not sure it will help but if I suggest that you have the car forget your phone and/or have your phone's bluetooth forget the car (not sure if you need to or can do both). Then power your phone completely off. Power it back on on and do a new pairing procedure with the car, making sure that CarPlay is enabled on the phone.

Hope this helps.
__________________
2020 F87 M2C Hockenheim Silver/MT
2002 E39 M5 Sterling Gray/Caramel
2007 E86 Z4M Coupe Silver Gray/Black
2016 F80 M3 ZCP MG/Golden Brown/6MT European Delivery Thread - gone
Appreciate 0
      11-29-2019, 02:33 PM   #14
Hingle Mccringleberry
Enlisted Member
Hingle Mccringleberry's Avatar
36
Rep
32
Posts

Drives: '20 M2C
Join Date: Jun 2015
Location: NC

iTrader: (0)

Is your phone connected when you startup, but you have to go through the idrive to get it to display? If so, the start-up screen on the idrive is set with your seat memory buttons. Put the idrive on the Carplay screen, then push the seat program button and assign 1 or 2. This may or may not help
Appreciate 0
      11-29-2019, 07:30 PM   #15
Daytona_550
Private First Class
Daytona_550's Avatar
United_States
87
Rep
122
Posts

Drives: 2020 M2C / 2008 550i Sport
Join Date: Oct 2019
Location: Daytona Beach

iTrader: (0)

Quote:
Originally Posted by Hingle Mccringleberry View Post
Is your phone connected when you startup, but you have to go through the idrive to get it to display? If so, the start-up screen on the idrive is set with your seat memory buttons. Put the idrive on the Carplay screen, then push the seat program button and assign 1 or 2. This may or may not help
Oooh, I will definitely be trying this! Always wondered why it started up on a useless screen (probably the one that was on when I set the seat/mirror memory). What else is "remembered" by the memory button?
Appreciate 0
      11-30-2019, 12:14 PM   #16
Flange
Private
United Kingdom
53
Rep
82
Posts

Drives: M2C
Join Date: Oct 2014
Location: Location, Location....

iTrader: (0)

I’ve got CarPlay plugged into one of the memory buttons, but when I press it to start up CarPlay it always says something like ‘ CarPlay not currently available’ every time.
Appreciate 0
      12-01-2019, 03:56 PM   #17
Poochie
Luxury at the redline :)
Poochie's Avatar
United_States
3631
Rep
4,170
Posts

Drives: 2016 M2
Join Date: Aug 2012
Location: NYC

iTrader: (1)

CarPlay or any of BMW APPs are tied to the vehicle's Connectdrive system, which takes a few seconds to a minute to authenticate it's subscription validity, via the vehicle's independent data connection.

This is the reason CarPlay takes a little to populate on screen, as this handshake has to commence each time it's booted from scratch.
Appreciate 1
cptobvious2001.00

      12-01-2019, 10:37 PM   #18
goku7
Second Lieutenant
goku7's Avatar
United_States
130
Rep
220
Posts

Drives: 2020 BMW M2C
Join Date: Nov 2018
Location: Bay Area, CA

iTrader: (0)

For me I see the bmw dismiss screen in my phone on car start but on gods green earth I'm not able to find where is CarPlay in my m2
Appreciate 0
      12-02-2019, 02:06 PM   #19
5150d
Enlisted Member
50
Rep
49
Posts

Drives: BMW M2 Competition
Join Date: Apr 2019
Location: USA

iTrader: (0)

FINALLY SOLVED (sort of): The Apple Car Play is handled via WI-FI. If you connect your iPhone via Bluetooth it may work sometimes and be unreliable.

I found this out by forgetting the Bluetooth connection in the iPhone and in the M2 and then restarting the iPhone and the M2.

YOU NEED TO CONNECT THE iPhone via the APPLE CAR PLAY icon in the M2 - NOT VIA CONNECT PHONE THROUGH BLUETOOTH. IT WILL THEN BOOT UP THE CAR PLAY AND CONNECT.

If successful you will see the connection in your iPhone settings under WI-FI (apple car play connected). Bluetooth does show the M2 PAIRED but it does not connect via that. And, yes, there is a check box in the Bluetooth section of the M2 that does say use Apple Car Play and it is checked BUT the important point is that when you go to ADD MOBILE DEVICE in the M2 you need to click on the APPLE CAR PLAY icon (in the M2) NOT the Pair Phone.

I got to this point because I repeatedly got the screen in in the M2 when I tried to pair the iPhone via Bluetooth clicking on pair phone in add mobile device WHICH said apple car play failed. Don't click on that.

The Apple Car Play still does not come on at Start Up as the standard BMW menu comes on BUT it does immediately show the Apple Car Play icon which I have to touch to bring it up. And, the BMW iDrive navigation works at same time which it did not work when using Bluetooth. ALSO - YOU CAN PRESS THE VOICE BOTTON ON THE STEERING WHEEL AND SAY "CARPLAY" AND IT WILL BOOT UP ON SCREEN.

Please advise if this works for you and if I am correct?

Last edited by 5150d; 12-04-2019 at 06:52 PM..
Appreciate 2
goku7129.50

      12-04-2019, 04:06 PM   #20
Inuyasha
“One finds limits by pushing them”
Inuyasha's Avatar
106
Rep
505
Posts

Drives: M2C
Join Date: Dec 2006
Location: NYC

iTrader: (0)

I will try this.
Appreciate 0
      12-04-2019, 08:28 PM   #21
Tag
Major General
Tag's Avatar
United_States
4787
Rep
5,081
Posts

Drives: Bimmer
Join Date: Jan 2007
Location: Chicago

iTrader: (2)

Man, this thread gave me flashbacks of trying to get the old BMW USB 6FL interface (that thing was a pos) to load up mp3 tracks and display alerts/messages via Bluetooth. It's now 2019 going on 2020 and there are still stupid issues like this; it shouldn't be that hard. Tired of poorly written protocols and apps.

P.S. I work in tech, there are no excuse for this IMO.

P.S.S. When will AI take over already?
Appreciate 0
      12-08-2019, 11:45 AM   #22
neurostrokemd
New Member
neurostrokemd's Avatar
Canada
14
Rep
19
Posts

Drives: M2C 2020 6MT
Join Date: Jun 2019
Location: SoCal

iTrader: (0)

Garage List
Quote:
Originally Posted by 5150d View Post
FINALLY SOLVED (sort of): The Apple Car Play is handled via WI-FI. If you connect your iPhone via Bluetooth it may work sometimes and be unreliable.

I found this out by forgetting the Bluetooth connection in the iPhone and in the M2 and then restarting the iPhone and the M2.

YOU NEED TO CONNECT THE iPhone via the APPLE CAR PLAY icon in the M2 - NOT VIA CONNECT PHONE THROUGH BLUETOOTH. IT WILL THEN BOOT UP THE CAR PLAY AND CONNECT.

If successful you will see the connection in your iPhone settings under WI-FI (apple car play connected). Bluetooth does show the M2 PAIRED but it does not connect via that. And, yes, there is a check box in the Bluetooth section of the M2 that does say use Apple Car Play and it is checked BUT the important point is that when you go to ADD MOBILE DEVICE in the M2 you need to click on the APPLE CAR PLAY icon (in the M2) NOT the Pair Phone.

I got to this point because I repeatedly got the screen in in the M2 when I tried to pair the iPhone via Bluetooth clicking on pair phone in add mobile device WHICH said apple car play failed. Don't click on that.

The Apple Car Play still does not come on at Start Up as the standard BMW menu comes on BUT it does immediately show the Apple Car Play icon which I have to touch to bring it up. And, the BMW iDrive navigation works at same time which it did not work when using Bluetooth. ALSO - YOU CAN PRESS THE VOICE BOTTON ON THE STEERING WHEEL AND SAY "CARPLAY" AND IT WILL BOOT UP ON SCREEN.

Please advise if this works for you and if I am correct?
I was not going to use car play with my work phone but I gave it a go after they announced it free. However I only got iphone to pair bluetooth. There's nowhere in the entire iDrive system where I can find Apple car play icon. There's yelp, amazon alexa etc.
Appreciate 1
goku7129.50

Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 10:40 AM.




m2
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST