BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
M2 Technical Topics > S55 Engine / Drivetrain / Exhaust / Bolt-ons / Tuning > Ticking sound coming from the engine

Post Reply
 
Thread Tools Search this Thread
      12-08-2019, 04:27 PM   #1
m20e3087
Lieutenant
m20e3087's Avatar
United_States
305
Rep
597
Posts

Drives: 19 M2C
Join Date: Mar 2012
Location: FL

iTrader: (0)

Garage List
2019 BMW M2C  [0.00]
I had my car parked for several hours and when I went to get few items out of my car engine started to tick, locked it agin and opened the doors and still having same issue. Anyone experienced this with their S55?

Last edited by m20e3087; 12-11-2019 at 10:31 AM..
Appreciate 0
      12-11-2019, 10:31 AM   #2
m20e3087
Lieutenant
m20e3087's Avatar
United_States
305
Rep
597
Posts

Drives: 19 M2C
Join Date: Mar 2012
Location: FL

iTrader: (0)

Garage List
2019 BMW M2C  [0.00]
So now the sound is completely gone, however made few clips so I can show the SA. After doing some research found M3/M4 subform with same issue which maybe the root cause.

https://f80.bimmerpost.com/forums/sh....php?t=1389358
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 08:37 PM.




m2
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST