BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
M2 Technical Topics > Mechanical Maintenance: Break-in | Oil & Fluids | Servicing | TSB | Recalls > Suspension Squeaking

Post Reply
 
Thread Tools Search this Thread
      07-17-2018, 09:39 PM   #1
Mosely
Lieutenant
Mosely's Avatar
428
Rep
402
Posts

Drives: '18 LBB M2 6MT
Join Date: Mar 2017
Location: SoCal

iTrader: (0)

Suspension Squeaking

2018 M2, 4000 miles. I've noticed the suspension is starting to get really squeaky. Sounds like the fronts. It's much worse when the wheel is turned to the left but its starting to happen with the wheel straight over any bumps, big or small. Anyone deal with this before? I know the F80/82 M3/4 guys have had similar issues and it's required warranty strut replacements. Just trying to get an idea before I take it in for my annual service next month. Was planning on swapping for coils soon but if my stock suspension is jacked up I'd like to get it fixed before hand.
__________________
IG Photo Gallery:
instagram.com/dr_m2sko/

Appreciate 0
      07-20-2018, 12:54 PM   #2
$M2
Private
$M2's Avatar
71
Rep
87
Posts

Drives: 2019 X3 M40i
Join Date: Jun 2018
Location: USA

iTrader: (0)

Quote:
Originally Posted by Mosely View Post
2018 M2, 4000 miles. I've noticed the suspension is starting to get really squeaky. Sounds like the fronts. It's much worse when the wheel is turned to the left but its starting to happen with the wheel straight over any bumps, big or small. Anyone deal with this before? I know the F80/82 M3/4 guys have had similar issues and it's required warranty strut replacements. Just trying to get an idea before I take it in for my annual service next month. Was planning on swapping for coils soon but if my stock suspension is jacked up I'd like to get it fixed before hand.
I just picked up a 2018 and has less than 200 miles on it and the rear is beginning to squeak.
Appreciate 0
      07-20-2018, 09:44 PM   #3
GoneIn4Secs
Major
Canada
642
Rep
1,117
Posts

Drives: '18 M2
Join Date: Jun 2018
Location: gta Canada

iTrader: (0)

does this occur on the M perf suspension too?
Appreciate 0
      07-20-2018, 09:59 PM   #4
$M2
Private
$M2's Avatar
71
Rep
87
Posts

Drives: 2019 X3 M40i
Join Date: Jun 2018
Location: USA

iTrader: (0)

Quote:
Originally Posted by GoneIn4Secs View Post
does this occur on the M perf suspension too?
Running stock suspension.
Appreciate 0
      07-23-2018, 06:30 PM   #5
pruettfan
Brigadier General
1536
Rep
3,415
Posts

Drives: 2017 M2, LBB, DCT, Exec
Join Date: Jul 2009
Location: Oro Valley, AZ

iTrader: (0)

After spending the last 9 weeks driving these crappy Houston roads I am surprised anyone can tolerate an M2 on these streets. Happy I left mine in AZ. Seriously though I doubt it is a strut issue, the rubber bushings are likely the culprit. Having said that it never hurts to take it to the dealer and have them take a look.

The roads in Houston really suck though
Appreciate 0
      08-22-2018, 10:51 PM   #6
Topsfield_BMW_fan
Registered
0
Rep
1
Posts

Drives: 2017 BMW M2
Join Date: Feb 2017
Location: Topsfield, MA

iTrader: (0)

M2 rear suspension noise

I find once, maybe twice, a day I hear a "chunk" from the rear of my 2016 M2 (7000 pretty mild miles.) Stock suspension, no mods. I've heard it now and then since just a thousand miles or so, and while surprising each time, it doesn't manifest in any noticeable change of feel or physical sensation at all. Sounds to me like a spring squirming on its perch perhaps, though it's often when turning but not under much squat or intense throttle/handling. I'd be surprised if that could happen on such a modern car. Any ideas?
Appreciate 0
      09-14-2018, 01:04 PM   #7
jessetaylor1
Second Lieutenant
133
Rep
246
Posts

Drives: 2018 AW LCI
Join Date: Nov 2017
Location: New Jersey

iTrader: (0)

Any updates on this? I'm hearing a clunking sound sometimes going over pretty big bumps on what seems to be both front wheels. Driving straight or turned. 6,500 miles 2018.
Appreciate 0
      07-11-2019, 04:50 PM   #8
Mosely
Lieutenant
Mosely's Avatar
428
Rep
402
Posts

Drives: '18 LBB M2 6MT
Join Date: Mar 2017
Location: SoCal

iTrader: (0)

Bumping my old thread here to see if anyone else has had a creaky front suspension and what they did? Mine creaks from the front passenger side when going over bumps in a straight line (can really hear it at low speed) and when hitting small bumps while the wheel is turned left. It goes away when turning right and it doesn't happy when you turn the wheel back and forth while stopped.

I do have KW V3 coilovers but it made the exact same noise when on stock suspension so it's something unrelated to the actual shock/spring, but it has progressively gotten louder and seems worse when it's hot outside. First noticed it with maybe 1500 miles on the car, currently have ~7500.

In retrospect, I should have taken it in for BMW to look at before installing the KWs since they will just blame the coils, and I don't have the energy to redo the whole install x 2 right now. I plan on taking everything off about 6 months before warranty expires and having all these little things looked over before re-installing them but was wondering if you guys had any thoughts right now?

Thanks!
__________________
IG Photo Gallery:
instagram.com/dr_m2sko/

Appreciate 0
      07-11-2019, 05:14 PM   #9
M Fifty
Captain
271
Rep
747
Posts

Drives: M2 & 330CI
Join Date: May 2018
Location: The Interweb

iTrader: (0)

Quote:
Originally Posted by pruettfan View Post
After spending the last 9 weeks driving these crappy Houston roads I am surprised anyone can tolerate an M2 on these streets. Happy I left mine in AZ. Seriously though I doubt it is a strut issue, the rubber bushings are likely the culprit. Having said that it never hurts to take it to the dealer and have them take a look.

The roads in Houston really suck though
I prefer DFW. You've just merged into 6 running lanes from the right and the satnav tells you to exit from the left in half a mile...
Appreciate 0
      07-11-2019, 10:53 PM   #10
Anthony1s
Lieutenant Colonel
1061
Rep
1,617
Posts

Drives: 2018 Mineral Grey M2
Join Date: Oct 2017
Location: Pennsylvania

iTrader: (0)

There is some more talk of front suspension noises here. https://f87.bimmerpost.com/forums/sh....php?t=1425894

Mine appeared after installing the KW v3's and Dinan front and rear bars.

In the next week or so I'm getting a DP installed and will also be replacing the strut carrier nuts and bolts, the stiffening plate bolts, and retorquing the axle support bolts. Actually, there is no front axle, so funny BMW calls it "front axle support bolts"

Other thoughts are to drive with the end links disconnected to see if the noise goes away, if it does the end links could be the culprit. Also to replace the strut top mount bolts. Maybe replace the top mounts and bolts too. I'll explore these things if the above doesn't solve my issue.

Here is a pdf I was sent of BMW's diagnosis procedure. They also list re-lubricating the wheel bearings. It's $60 for the recommended lube though and seems like a big process that I don't want to get into at this point.
Attached Images
File Type: pdf SI B31 03 18 Attachment.pdf (742.1 KB, 173 views)
__________________
Click "Appreciate" on my post if I was helpful. Thanks!
Appreciate 1
Mosely427.50

      07-12-2019, 09:22 AM   #11
jessetaylor1
Second Lieutenant
133
Rep
246
Posts

Drives: 2018 AW LCI
Join Date: Nov 2017
Location: New Jersey

iTrader: (0)

I don't have a creaking, but I have a clunking/knocking noise from front suspension when going over larger bumps going below 40MPH.
Appreciate 0
      07-13-2019, 03:17 PM   #12
Mosely
Lieutenant
Mosely's Avatar
428
Rep
402
Posts

Drives: '18 LBB M2 6MT
Join Date: Mar 2017
Location: SoCal

iTrader: (0)

Quote:
Originally Posted by Anthony1s View Post
There is some more talk of front suspension noises here. https://f87.bimmerpost.com/forums/sh....php?t=1425894

Mine appeared after installing the KW v3's and Dinan front and rear bars.

In the next week or so I'm getting a DP installed and will also be replacing the strut carrier nuts and bolts, the stiffening plate bolts, and retorquing the axle support bolts. Actually, there is no front axle, so funny BMW calls it "front axle support bolts"

Other thoughts are to drive with the end links disconnected to see if the noise goes away, if it does the end links could be the culprit. Also to replace the strut top mount bolts. Maybe replace the top mounts and bolts too. I'll explore these things if the above doesn't solve my issue.

Here is a pdf I was sent of BMW's diagnosis procedure. They also list re-lubricating the wheel bearings. It's $60 for the recommended lube though and seems like a big process that I don't want to get into at this point.
Thanks for the detailed reply! I had been following that thread too. I'm going to fiddle around with the endlinks. I also saw on the F80 forum that the rubber boot on the strut can be the culprit, so I'm going to have a look at that. Other thing to check is the torque on the top mount bolt supposedly. Let us know if you figure yours out and I'll do the same!
__________________
IG Photo Gallery:
instagram.com/dr_m2sko/

Appreciate 0
      07-14-2019, 12:27 PM   #13
Anthony1s
Lieutenant Colonel
1061
Rep
1,617
Posts

Drives: 2018 Mineral Grey M2
Join Date: Oct 2017
Location: Pennsylvania

iTrader: (0)

Quote:
Originally Posted by Mosely View Post
Thanks for the detailed reply! I had been following that thread too. I'm going to fiddle around with the endlinks. I also saw on the F80 forum that the rubber boot on the strut can be the culprit, so I'm going to have a look at that. Other thing to check is the torque on the top mount bolt supposedly. Let us know if you figure yours out and I'll do the same!
I just realized you're the one who made the giant KW v3 install guide. So you probably replaced the bolts I listed when you installed your coilovers.

Quick update from me. My DP arrived damaged, so I have to wait a bit longer to proceed with my suspension noise ideas. Back when I had my KW's and sway bars installed, my mechanic and I went through and replaced every bolt he took out. I was kinda hoping we missed the bolts I mentioned above, but so far that doesn't seem to be the case. Because my mechanic gave me back all of the "not reused" bolts from the install and they match the stiffening plate bolts I got in the mail Friday. I have 12 in my bag, which is 8 stiffening plate bolts and 4 rear suspension brace bolts. So seems to me they were replaced during the install. Either way, they have to get replaced again with the downpipe install, so it's not like I bought them for no reason.

Once I get the carrier bolts and top hat bolts in the mail, I'll compare them to them to my bag of "not reused" bolts and see if they were replaced already too.
__________________
Click "Appreciate" on my post if I was helpful. Thanks!
Appreciate 0
      07-16-2019, 05:42 AM   #14
KeepItlow
Enlisted Member
KeepItlow's Avatar
Australia
40
Rep
36
Posts

Drives: Car
Join Date: Jun 2018
Location: Sydney, Australia

iTrader: (0)

My 2017 M2 LCI had front right suspension clunk when going over humps or driveway entry at low speed, thing is it doesn't always happen so I didn't bother to look into it and later sold the car..
Appreciate 0
      09-20-2019, 12:53 PM   #15
biomechaniod
Registered
0
Rep
4
Posts

Drives: E46 M3
Join Date: Jun 2019
Location: Seattle, WA

iTrader: (0)

I want to add my recent experience in case it's helpful to anyone...

I took delivery of a 2020 M2 Comp in August. Right away I noticed a significant metallic ping, creak, or tick sound coming from the front suspension. It would happen when entering my driveway or articulating the front suspension but also when turning the steering wheel while maneuvering into a parking spot. It was not a repeating rotational noise associated with the front wheels turning or related to applying the brakes. It sounded like something was loose or shifting whenever a load was applied.

They checked out the calipers and tried the shim fix between the hub and disc. The dealer eventually diagnosed it as a problem on the upper front strut. They ordered new guide supports and washers (basically the upper mounting of the strut where it bolts to the frame) and replaced both driver and passenger side parts.

It appears to have fixed the problem so far...
Appreciate 0
      09-20-2019, 02:20 PM   #16
M Fifty
Captain
271
Rep
747
Posts

Drives: M2 & 330CI
Join Date: May 2018
Location: The Interweb

iTrader: (0)

Quote:
Originally Posted by GoneIn4Secs View Post
does this occur on the M perf suspension too?
I have squeaky rear M perf suspension.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 08:16 PM.




m2
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST