BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW M2 Forum > BMW M2 Discussions > LED Adaptive Headlights w/ Variable Light Distribution (VLD) - High Beam Assist (HBA)

Post Reply
 
Thread Tools Search this Thread
      01-25-2018, 12:03 AM   #45
scadagawd
Second Lieutenant
scadagawd's Avatar
Canada
22
Rep
234
Posts

Drives: BMW M2 2018
Join Date: Jul 2016
Location: Vancouver, BC

iTrader: (0)

Quote:
Originally Posted by Nezil View Post
Quote:
Originally Posted by scadagawd View Post
Nezil after coding how can you tell you have enabled VLD?
The easiest way is to park near to a wall at night, and set your headlights to Auto. VLD only works in Auto, not when you manually switch to 'On', and not when you're in reverse either.

So, switch between 1st and Reverse, or Auto and On, and you'll see a big difference. Then, when in Auto, move the steering left and right just a little, and you'll see the headlights pivot way more than they did before you enabled VLD.

Then... go for a drive... it should be pretty obvious!
Thanks. I'll try it.
__________________
BMW M2 2018 LBB
BMW X1 2016 PSM
Audi S4 2014 SMG
Appreciate 0
      01-25-2018, 05:06 AM   #46
akkando
Brigadier General
3075
Rep
4,165
Posts

Drives: 17 M2 DCT LBB,11 e90 M3 ZCP IB
Join Date: Jan 2017
Location: Bay Area

iTrader: (1)

Quote:
Originally Posted by Nezil View Post
The easiest way is to park near to a wall at night, and set your headlights to Auto. VLD only works in Auto, not when you manually switch to 'On', and not when you're in reverse either.

So, switch between 1st and Reverse, or Auto and On, and you'll see a big difference. Then, when in Auto, move the steering left and right just a little, and you'll see the headlights pivot way more than they did before you enabled VLD.

Then... go for a drive... it should be pretty obvious!
Just coded it on my MY17. I should have done before and after to make sure it's moving the lights more that it did before but I did not. I did verify that my headlights WORK after I coded the values though so seems like low risk at least!
Appreciate 0
      01-25-2018, 05:54 AM   #47
Bt12
Captain
384
Rep
962
Posts

Drives: 2018 X5,2018 m2, 2018 x1
Join Date: Sep 2017
Location: Bicoastal

iTrader: (0)

This is cool. Going to do this tonight.
Appreciate 0
      01-25-2018, 12:50 PM   #48
scadagawd
Second Lieutenant
scadagawd's Avatar
Canada
22
Rep
234
Posts

Drives: BMW M2 2018
Join Date: Jul 2016
Location: Vancouver, BC

iTrader: (0)

Just curious if VLD is such a great feature and it's used in Europe, why is it disabled in Canada and the US? If VLD could potentially cause accidents (I guess that's why it's turned off?) in NA, wouldn't it have the same effect in Europe? Thoughts?
__________________
BMW M2 2018 LBB
BMW X1 2016 PSM
Audi S4 2014 SMG
Appreciate 0
      01-25-2018, 05:37 PM   #49
andrewc89
Colonel
andrewc89's Avatar
United_States
6738
Rep
2,916
Posts

Drives: 2017 M2 | 2015 328dx
Join Date: Aug 2010
Location: New Jersey

iTrader: (5)

Garage List
2017 M2  [5.00]
2015 328d xDrive  [0.00]
Quote:
Originally Posted by akkando View Post

Just coded it on my MY17. I should have done before and after to make sure it's moving the lights more that it did before but I did not. I did verify that my headlights WORK after I coded the values though so seems like low risk at least!
I can confirm the coding works on my PreLCI

Easy way to check is to start the engine and turn on your headlights.
Look where the left beam is pointing and then turn on your high beams.
You'll see the left headlight moving around from left to right.

Last edited by andrewc89; 01-25-2018 at 05:53 PM..
Appreciate 1
bmwm2nyc225.00

      01-25-2018, 07:50 PM   #50
Wharf Rat
First Lieutenant
176
Rep
330
Posts

Drives: ...
Join Date: Aug 2017
Location: Southwest

iTrader: (0)

Quote:
Originally Posted by scadagawd View Post
Just curious if VLD is such a great feature and it's used in Europe, why is it disabled in Canada and the US? If VLD could potentially cause accidents (I guess that's why it's turned off?) in NA, wouldn't it have the same effect in Europe? Thoughts?
My guess, and it's just a guess, is that it's because we are such a nanny society. Tons of legislation to "protect us from ourselves."

I believe the reason it is disabled on import cars is because of DOT regulations.
Appreciate 2
      01-25-2018, 08:52 PM   #51
akkando
Brigadier General
3075
Rep
4,165
Posts

Drives: 17 M2 DCT LBB,11 e90 M3 ZCP IB
Join Date: Jan 2017
Location: Bay Area

iTrader: (1)

Quote:
Originally Posted by Wharf Rat View Post
My guess, and it's just a guess, is that it's because we are such a nanny society. Tons of legislation to "protect us from ourselves."

I believe the reason it is disabled on import cars is because of DOT regulations.
I think it's some old regulation from like the 60s that just was never updated and it's easier to do nothing than it is to do something. For VLD it seems of little risk of blinding other drivers because it's not flashing the high beams and I can't imagine the coppers or anyone would notice something is up with your headlights.
Appreciate 1
      01-26-2018, 01:25 AM   #52
scadagawd
Second Lieutenant
scadagawd's Avatar
Canada
22
Rep
234
Posts

Drives: BMW M2 2018
Join Date: Jul 2016
Location: Vancouver, BC

iTrader: (0)

Coded VLD and tested it tonight and it works really well. Too bad they have to disable this feature.
__________________
BMW M2 2018 LBB
BMW X1 2016 PSM
Audi S4 2014 SMG
Appreciate 0
      01-26-2018, 12:44 PM   #53
scadagawd
Second Lieutenant
scadagawd's Avatar
Canada
22
Rep
234
Posts

Drives: BMW M2 2018
Join Date: Jul 2016
Location: Vancouver, BC

iTrader: (0)

Just curious, do most of you who have HBA leave this turn on even when driving in the city or do you use this feature only on highways with fewer vehicles? I currently have it off as I'm not sure how effective this works in the City.
__________________
BMW M2 2018 LBB
BMW X1 2016 PSM
Audi S4 2014 SMG
Appreciate 0
      01-26-2018, 04:18 PM   #54
akkando
Brigadier General
3075
Rep
4,165
Posts

Drives: 17 M2 DCT LBB,11 e90 M3 ZCP IB
Join Date: Jan 2017
Location: Bay Area

iTrader: (1)

Quote:
Originally Posted by scadagawd View Post
Just curious, do most of you who have HBA leave this turn on even when driving in the city or do you use this feature only on highways with fewer vehicles? I currently have it off as I'm not sure how effective this works in the City.
Off because high beams don't make sense for where I drive anyway and I don't want it making a mistake and blinding someone, though in theory it shouldn't.
Appreciate 0
      01-27-2018, 12:55 AM   #55
Wharf Rat
First Lieutenant
176
Rep
330
Posts

Drives: ...
Join Date: Aug 2017
Location: Southwest

iTrader: (0)

Quote:
Originally Posted by akkando View Post
Off because high beams don't make sense for where I drive anyway and I don't want it making a mistake and blinding someone, though in theory it shouldn't.
Blinding someone? Really? In all my decades of driving I've never heard of anyone being blinded because an opposing car had its high beam on. Geez... Have we become this soft?
Appreciate 0
      01-27-2018, 04:15 AM   #56
akkando
Brigadier General
3075
Rep
4,165
Posts

Drives: 17 M2 DCT LBB,11 e90 M3 ZCP IB
Join Date: Jan 2017
Location: Bay Area

iTrader: (1)

Quote:
Originally Posted by Wharf Rat View Post
Blinding someone? Really? In all my decades of driving I've never heard of anyone being blinded because an opposing car had its high beam on. Geez... Have we become this soft?
I didn't literally mean blind. Anyway I don't need them and I don't want the high beams annoying people. You can use yours as you wish.
Appreciate 1
      03-24-2018, 01:04 PM   #57
jmh600cbr
Second Lieutenant
jmh600cbr's Avatar
Canada
132
Rep
275
Posts

Drives: F87
Join Date: Nov 2017
Location: Toronto

iTrader: (0)

Quote:
Originally Posted by andrewc89 View Post
Quote:
Originally Posted by evilIu4 View Post
wondering what would it take to code VLD on my LCI

I already have bimmercode and hesitant to go about coding with e-sys.
VLD with bimmercode:

Front Electronic Module > Expert Mode >

3073 LaMaster1 > LUT_FLC_FORWARDLIGHTING_Y > 9C,9C,9C (Both)

3073 LaMaster1 > C_AFS_ENA > Enable (Both)

Note: You'll see two check marks. If you tap the top one, the bottom one will go away. Make your selection. Back out. Go back in. Both correct selections should have the blue check mark next to them.

Quote:
Originally Posted by Perp View Post
I'm guessing you need adaptive option to get VLD working?
yes
Thanks for this. How will I know it worked?
__________________
2018 F87 LCI
Appreciate 1
      03-24-2018, 01:19 PM   #58
andrewc89
Colonel
andrewc89's Avatar
United_States
6738
Rep
2,916
Posts

Drives: 2017 M2 | 2015 328dx
Join Date: Aug 2010
Location: New Jersey

iTrader: (5)

Garage List
2017 M2  [5.00]
2015 328d xDrive  [0.00]
Quote:
Originally Posted by jmh600cbr View Post
Quote:
Originally Posted by andrewc89 View Post
Quote:
Originally Posted by evilIu4 View Post
wondering what would it take to code VLD on my LCI

I already have bimmercode and hesitant to go about coding with e-sys.
VLD with bimmercode:

Front Electronic Module > Expert Mode >

3073 LaMaster1 > LUT_FLC_FORWARDLIGHTING_Y > 9C,9C,9C (Both)

3073 LaMaster1 > C_AFS_ENA > Enable (Both)

Note: You'll see two check marks. If you tap the top one, the bottom one will go away. Make your selection. Back out. Go back in. Both correct selections should have the blue check mark next to them.

Quote:
Originally Posted by Perp View Post
I'm guessing you need adaptive option to get VLD working?
yes
Thanks for this. How will I know it worked?
Set the lights to auto in your garage or facing a wall when it's dark out. Turn the car on and then pull the high beam lever. You'll see the drivers side beam move left to right every time you switch from low to high.
Appreciate 0
      03-24-2018, 01:21 PM   #59
jmh600cbr
Second Lieutenant
jmh600cbr's Avatar
Canada
132
Rep
275
Posts

Drives: F87
Join Date: Nov 2017
Location: Toronto

iTrader: (0)

Quote:
Originally Posted by andrewc89 View Post
Quote:
Originally Posted by jmh600cbr View Post
Quote:
Originally Posted by andrewc89 View Post
Quote:
Originally Posted by evilIu4 View Post
wondering what would it take to code VLD on my LCI

I already have bimmercode and hesitant to go about coding with e-sys.
VLD with bimmercode:

Front Electronic Module > Expert Mode >

3073 LaMaster1 > LUT_FLC_FORWARDLIGHTING_Y > 9C,9C,9C (Both)

3073 LaMaster1 > C_AFS_ENA > Enable (Both)

Note: You'll see two check marks. If you tap the top one, the bottom one will go away. Make your selection. Back out. Go back in. Both correct selections should have the blue check mark next to them.

Quote:
Originally Posted by Perp View Post
I'm guessing you need adaptive option to get VLD working?
yes
Thanks for this. How will I know it worked?
Set the lights to auto in your garage or facing a wall when it's dark out. Turn the car on and then pull the high beam lever. You'll see the drivers side beam move left to right every time you switch from low to high.
Thanks ill try it tonight. That said, it works with the High beam off yeah? Like the VlD only works with low beam and moves based on the steering wheel?
__________________
2018 F87 LCI
Appreciate 0
      03-24-2018, 01:26 PM   #60
andrewc89
Colonel
andrewc89's Avatar
United_States
6738
Rep
2,916
Posts

Drives: 2017 M2 | 2015 328dx
Join Date: Aug 2010
Location: New Jersey

iTrader: (5)

Garage List
2017 M2  [5.00]
2015 328d xDrive  [0.00]
Quote:
Originally Posted by jmh600cbr View Post
Quote:
Originally Posted by andrewc89 View Post
Quote:
Originally Posted by jmh600cbr View Post
Quote:
Originally Posted by andrewc89 View Post
Quote:
Originally Posted by evilIu4 View Post
wondering what would it take to code VLD on my LCI

I already have bimmercode and hesitant to go about coding with e-sys.
VLD with bimmercode:

Front Electronic Module > Expert Mode >

3073 LaMaster1 > LUT_FLC_FORWARDLIGHTING_Y > 9C,9C,9C (Both)

3073 LaMaster1 > C_AFS_ENA > Enable (Both)

Note: You'll see two check marks. If you tap the top one, the bottom one will go away. Make your selection. Back out. Go back in. Both correct selections should have the blue check mark next to them.

Quote:
Originally Posted by Perp View Post
I'm guessing you need adaptive option to get VLD working?
yes
Thanks for this. How will I know it worked?
Set the lights to auto in your garage or facing a wall when it's dark out. Turn the car on and then pull the high beam lever. You'll see the drivers side beam move left to right every time you switch from low to high.
Thanks ill try it tonight. That said, it works with the High beam off yeah? Like the VlD only works with low beam and moves based on the steering wheel?
Variable Light Distribution has several different modes of operation (for Low Beam):

1 - City Light: Shallow and Very Wide Beam Pattern active from 0 - 50kph (30MPH) (Both Headlamps are Panned outwards 12 horizontal from center and 0.7 lowered vertically)

2 - Standard Light: Same Basic Beam Pattern as with 8S4 Enabled and Headlamp Switch Set to Auto. Active from 50 - 110kph (30MPH - 68MPH)

3 - Guiding Fog Light - Shallow and Wider Beam Pattern Enabled with the Front Fog Lamps On and Headlamp Switch in Auto and Speed 0 - 110kph (Both headlamps are panned outwards 8 horizontal from center and lowered 0.7 vertically)

4 - Highway Light - Long Throw Pattern illuminating approx. 25% further than Standard Light. Active from 110 to 250kph (68MPH- 155MHP). (Driver's Side Headlamp is panned 3.5 outwards Horizontal from center and lowered 0.25 vertically, while the passenger side headlamp is raised 0.2 vertical)

It only works on your low beams to move your headlights and position the beams on the road depending on steering angle and vehicle speed.
Appreciate 3
jmh600cbr131.50
Poochie3680.50

      03-24-2018, 04:11 PM   #61
Poochie
Luxury at the redline :)
Poochie's Avatar
United_States
3681
Rep
4,222
Posts

Drives: 2016 M2
Join Date: Aug 2012
Location: NYC

iTrader: (1)

Quote:
Originally Posted by andrewc89 View Post
Quote:
Originally Posted by jmh600cbr View Post
Quote:
Originally Posted by andrewc89 View Post
Quote:
Originally Posted by jmh600cbr View Post
Quote:
Originally Posted by andrewc89 View Post
Quote:
Originally Posted by evilIu4 View Post
wondering what would it take to code VLD on my LCI

I already have bimmercode and hesitant to go about coding with e-sys.
VLD with bimmercode:

Front Electronic Module > Expert Mode >

3073 LaMaster1 > LUT_FLC_FORWARDLIGHTING_Y > 9C,9C,9C (Both)

3073 LaMaster1 > C_AFS_ENA > Enable (Both)

Note: You'll see two check marks. If you tap the top one, the bottom one will go away. Make your selection. Back out. Go back in. Both correct selections should have the blue check mark next to them.

Quote:
Originally Posted by Perp View Post
I'm guessing you need adaptive option to get VLD working?
yes
Thanks for this. How will I know it worked?
Set the lights to auto in your garage or facing a wall when it's dark out. Turn the car on and then pull the high beam lever. You'll see the drivers side beam move left to right every time you switch from low to high.
Thanks ill try it tonight. That said, it works with the High beam off yeah? Like the VlD only works with low beam and moves based on the steering wheel?
Variable Light Distribution has several different modes of operation (for Low Beam):

1 - City Light: Shallow and Very Wide Beam Pattern active from 0 - 50kph (30MPH) (Both Headlamps are Panned outwards 12 horizontal from center and 0.7 lowered vertically)

2 - Standard Light: Same Basic Beam Pattern as with 8S4 Enabled and Headlamp Switch Set to Auto. Active from 50 - 110kph (30MPH - 68MPH)

3 - Guiding Fog Light - Shallow and Wider Beam Pattern Enabled with the Front Fog Lamps On and Headlamp Switch in Auto and Speed 0 - 110kph (Both headlamps are panned outwards 8 horizontal from center and lowered 0.7 vertically)

4 - Highway Light - Long Throw Pattern illuminating approx. 25% further than Standard Light. Active from 110 to 250kph (68MPH- 155MHP). (Driver's Side Headlamp is panned 3.5 outwards Horizontal from center and lowered 0.25 vertically, while the passenger side headlamp is raised 0.2 vertical)

It only works on your low beams to move your headlights and position the beams on the road depending on steering angle and vehicle speed.



Anyone who also wants lower the speed for which No. 4 (Highway light) activates to 50mph:

FEM> 3073 > C_AFS_E_V_LO > Custom (0X50)

The default is "6E" which equals = 110KLM or 68MPH.

Coding "50" lowers the speed activation to 80KLM or 49.7MPH. Which I find more suitable.

Worked for me, good luck.
Appreciate 4
Dirtboy159.50
ZPrime552.50
Bosozoku640.00
andrewc896738.00

      06-01-2018, 06:31 PM   #62
GregoryK
Captain
GregoryK's Avatar
Canada
431
Rep
765
Posts

Drives: M2 '18
Join Date: Aug 2014
Location: Canada

iTrader: (0)

I know this is an old thread.
I have:
Autom. High-beam Headlights Control
5AP
Decoding For No-dazzle High-beam As
8S4
Decoding Variable Light Distribution

So when I try to enable VLD with Bimmercode Expert mode

I go to 3073 LaMaster1 > LUT_FLC_FORWARDLIGHTING_Y

There is no 9c,9c (or anything like that)
I get 4 options with radial buttons
F020_ohne_AFS
F020_mit_AFS
F020_ohne_AFS
F020_mit_AFS
Same for the second setting.

Any thoughts!

Thanks
__________________


"I would rather cry in a BMW than smile on a bicycle." Ma Nuo

Last edited by GregoryK; 06-01-2018 at 07:04 PM..
Appreciate 0
      06-01-2018, 07:43 PM   #63
andrewc89
Colonel
andrewc89's Avatar
United_States
6738
Rep
2,916
Posts

Drives: 2017 M2 | 2015 328dx
Join Date: Aug 2010
Location: New Jersey

iTrader: (5)

Garage List
2017 M2  [5.00]
2015 328d xDrive  [0.00]
Quote:
Originally Posted by GregoryK View Post
I know this is an old thread.
I have:
Autom. High-beam Headlights Control
5AP
Decoding For No-dazzle High-beam As
8S4
Decoding Variable Light Distribution

So when I try to enable VLD with Bimmercode Expert mode

I go to 3073 LaMaster1 > LUT_FLC_FORWARDLIGHTING_Y

There is no 9c,9c (or anything like that)
I get 4 options with radial buttons
F020_ohne_AFS
F020_mit_AFS
F020_ohne_AFS
F020_mit_AFS
Same for the second setting.

Any thoughts!

Thanks
'Mit' is what you want. See the triple 9C in light gray underneath?

Appreciate 2
      06-01-2018, 07:52 PM   #64
GregoryK
Captain
GregoryK's Avatar
Canada
431
Rep
765
Posts

Drives: M2 '18
Join Date: Aug 2014
Location: Canada

iTrader: (0)

Actually there is no 9c on mine anywhere And only F020 twice. Does not look like your post.
Thanx
Appreciate 0
      06-02-2018, 10:28 AM   #65
andrewc89
Colonel
andrewc89's Avatar
United_States
6738
Rep
2,916
Posts

Drives: 2017 M2 | 2015 328dx
Join Date: Aug 2010
Location: New Jersey

iTrader: (5)

Garage List
2017 M2  [5.00]
2015 328d xDrive  [0.00]
Quote:
Originally Posted by GregoryK View Post
Actually there is no 9c on mine anywhere And only F020 twice. Does not look like your post.
Thanx
Can you post a screen shot of what it looks like? It will make it a million times easier to help you and I want to ensure we're looking at the same thing.
Appreciate 1
bmwm2nyc225.00

      06-02-2018, 10:43 AM   #66
GregoryK
Captain
GregoryK's Avatar
Canada
431
Rep
765
Posts

Drives: M2 '18
Join Date: Aug 2014
Location: Canada

iTrader: (0)

Quote:
Originally Posted by andrewc89 View Post
Can you post a screen shot of what it looks like? It will make it a million times easier to help you and I want to ensure we're looking at the same thing.
Here's the demo screen. The actual one is the same except the F020 is repeated 4 times (no F030).

I am thinking of using E-Sys if I can't get it to work.
Attached Images
 
__________________


"I would rather cry in a BMW than smile on a bicycle." Ma Nuo
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 12:45 PM.




m2
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST