BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
M2 Technical Topics > Cosmetic Modifications > LED Bulb swap for NON-LCI Tails

Post Reply
 
Thread Tools Search this Thread
      08-18-2017, 05:58 AM   #23
DoggieHowser
First Lieutenant
201
Rep
361
Posts

Drives: F87 Pure F20 125i MSport 2017
Join Date: Apr 2017
Location: Australia

iTrader: (0)

Is there a guide to dismantling the tail lights to change the bulbs?

I think I prefer the pre LCI lights with LED to the LCI LED
Appreciate 0
      08-18-2017, 08:15 AM   #24
ChrisK
Major General
ChrisK's Avatar
United_States
3659
Rep
7,216
Posts

Drives: '19 M2C
Join Date: Jun 2007
Location: Chicagoland (West)

iTrader: (6)

Garage List
Quote:
Originally Posted by DoggieHowser View Post
Is there a guide to dismantling the tail lights to change the bulbs?

I think I prefer the pre LCI lights with LED to the LCI LED
^Agreed!


The instructions are in the manual, but take a look at this thread: http://www.2addicts.com/forums/showthread.php?t=1292702
__________________
www.ReTuneTheDeTune.com
2019 M2 Competition (Sunset Orange)
Appreciate 1
      08-18-2017, 01:08 PM   #25
Midn1ght
Enlisted Member
35
Rep
33
Posts

Drives: BMW M2
Join Date: Nov 2016
Location: Chicago

iTrader: (0)

I coded the cold checks to nonactive and the bulbs to led and I'm still getting the errors.
Appreciate 0
      08-18-2017, 01:52 PM   #26
ChrisK
Major General
ChrisK's Avatar
United_States
3659
Rep
7,216
Posts

Drives: '19 M2C
Join Date: Jun 2007
Location: Chicagoland (West)

iTrader: (6)

Garage List
Quote:
Originally Posted by Midn1ght View Post
I coded the cold checks to nonactive and the bulbs to led and I'm still getting the errors.
I also coded the warm checks to: Not Active
__________________
www.ReTuneTheDeTune.com
2019 M2 Competition (Sunset Orange)
Appreciate 0
      08-18-2017, 01:53 PM   #27
Midn1ght
Enlisted Member
35
Rep
33
Posts

Drives: BMW M2
Join Date: Nov 2016
Location: Chicago

iTrader: (0)

Quote:
Originally Posted by ChrisK View Post
Quote:
Originally Posted by Midn1ght View Post
I coded the cold checks to nonactive and the bulbs to led and I'm still getting the errors.
I also coded the warm checks to: Not Active
They are as well
Appreciate 0
      08-18-2017, 03:28 PM   #28
ChrisK
Major General
ChrisK's Avatar
United_States
3659
Rep
7,216
Posts

Drives: '19 M2C
Join Date: Jun 2007
Location: Chicagoland (West)

iTrader: (6)

Garage List
Quote:
Originally Posted by Midn1ght View Post
They are as well
Strange. Can you post a screen shot of the error?
__________________
www.ReTuneTheDeTune.com
2019 M2 Competition (Sunset Orange)
Appreciate 0
      08-19-2017, 11:44 AM   #29
Midn1ght
Enlisted Member
35
Rep
33
Posts

Drives: BMW M2
Join Date: Nov 2016
Location: Chicago

iTrader: (0)

Quote:
Originally Posted by ChrisK View Post
Quote:
Originally Posted by Midn1ght View Post
They are as well
Strange. Can you post a screen shot of the error?
Here are the errors. They go away as soon as I step on the brakes. Both cold and warm monitoring is turned off
Attached Images
 
Appreciate 0
      08-19-2017, 11:47 AM   #30
Midn1ght
Enlisted Member
35
Rep
33
Posts

Drives: BMW M2
Join Date: Nov 2016
Location: Chicago

iTrader: (0)

Quote:
Originally Posted by ChrisK View Post
Quote:
Originally Posted by Midn1ght View Post
They are as well
Strange. Can you post a screen shot of the error?
It's odd that I would be getting this error message with both monitoring turned off. Wouldn't you agree?
Appreciate 0
      08-19-2017, 01:34 PM   #31
DoggieHowser
First Lieutenant
201
Rep
361
Posts

Drives: F87 Pure F20 125i MSport 2017
Join Date: Apr 2017
Location: Australia

iTrader: (0)

Chris is driving a 2017 model. Is yours?
Appreciate 0
      08-19-2017, 07:33 PM   #32
ChrisK
Major General
ChrisK's Avatar
United_States
3659
Rep
7,216
Posts

Drives: '19 M2C
Join Date: Jun 2007
Location: Chicagoland (West)

iTrader: (6)

Garage List
Quote:
Originally Posted by Midn1ght View Post
Quote:
Originally Posted by ChrisK View Post
Quote:
Originally Posted by Midn1ght View Post
They are as well
Strange. Can you post a screen shot of the error?
Here are the errors. They go away as soon as I step on the brakes. Both cold and warm monitoring is turned off
Very weird. Maybe your car didn?t take the programming. Are you running the latest version?
__________________
www.ReTuneTheDeTune.com
2019 M2 Competition (Sunset Orange)
Appreciate 0
      08-20-2017, 12:16 PM   #33
bmwv
Private First Class
37
Rep
156
Posts

Drives: 325i Manual, M2 LBB DCT
Join Date: Jan 2006
Location: CA

iTrader: (0)

Garage List
2017 BMW M2  [0.00]
2006 BMW 325i  [0.00]
So the rear signals are red. Not amber?
Appreciate 0
      08-20-2017, 03:27 PM   #34
DoZZa
Private First Class
DoZZa's Avatar
United Kingdom
55
Rep
137
Posts

Drives: MY17 | M2 | DCT
Join Date: Jun 2017
Location: UK

iTrader: (0)

Quote:
Originally Posted by bmwv View Post
So the rear signals are red. Not amber?
Depends on your country I imagine.

Im from the UK so swapped two of the eight reds for amber. Amber is what is used for turn signals in the UK.
__________________
F87 M2 | DCT '17
E46 M3 |SMG '06
E46 M3 | SMG '03
E30 320iS | '90
E28 M535i | '84
Appreciate 0
      08-20-2017, 07:14 PM   #35
ChrisK
Major General
ChrisK's Avatar
United_States
3659
Rep
7,216
Posts

Drives: '19 M2C
Join Date: Jun 2007
Location: Chicagoland (West)

iTrader: (6)

Garage List
Quote:
Originally Posted by bmwv View Post
So the rear signals are red. Not amber?
US are red.
__________________
www.ReTuneTheDeTune.com
2019 M2 Competition (Sunset Orange)
Appreciate 0
      08-21-2017, 06:26 AM   #36
Midn1ght
Enlisted Member
35
Rep
33
Posts

Drives: BMW M2
Join Date: Nov 2016
Location: Chicago

iTrader: (0)

Quote:
Originally Posted by ChrisK View Post
Quote:
Originally Posted by Midn1ght View Post
Quote:
Originally Posted by ChrisK View Post
Quote:
Originally Posted by Midn1ght View Post
They are as well
Strange. Can you post a screen shot of the error?
Here are the errors. They go away as soon as I step on the brakes. Both cold and warm monitoring is turned off
Very weird. Maybe your car didn?t take the programming. Are you running the latest version?
Yes on the latest version and yes it took the coding. I wonder if this is something that has to be done in expert mode.
Appreciate 0
      08-21-2017, 07:07 AM   #37
ChrisK
Major General
ChrisK's Avatar
United_States
3659
Rep
7,216
Posts

Drives: '19 M2C
Join Date: Jun 2007
Location: Chicagoland (West)

iTrader: (6)

Garage List
Quote:
Originally Posted by Midn1ght View Post
Quote:
Originally Posted by ChrisK View Post
Quote:
Originally Posted by Midn1ght View Post
Quote:
Originally Posted by ChrisK View Post
Quote:
Originally Posted by Midn1ght View Post
They are as well
Strange. Can you post a screen shot of the error?
Here are the errors. They go away as soon as I step on the brakes. Both cold and warm monitoring is turned off
Very weird. Maybe your car didn?t take the programming. Are you running the latest version?
Yes on the latest version and yes it took the coding. I wonder if this is something that has to be done in expert mode.
I didn?t use expert mode for this.
__________________
www.ReTuneTheDeTune.com
2019 M2 Competition (Sunset Orange)
Appreciate 0
      08-29-2017, 04:19 PM   #38
Midn1ght
Enlisted Member
35
Rep
33
Posts

Drives: BMW M2
Join Date: Nov 2016
Location: Chicago

iTrader: (0)

It works

Well guys and gals the Phillips led 1156 bulbs were the problem. I used the bulbs the creator of this thread used and problem solved.

Thanks again
Appreciate 0
      08-29-2017, 06:31 PM   #39
ChrisK
Major General
ChrisK's Avatar
United_States
3659
Rep
7,216
Posts

Drives: '19 M2C
Join Date: Jun 2007
Location: Chicagoland (West)

iTrader: (6)

Garage List
Quote:
Originally Posted by Midn1ght View Post
Well guys and gals the Phillips led 1156 bulbs were the problem. I used the bulbs the creator of this thread used and problem solved.

Thanks again
I missed the fact that you choose the Phillips led's. As you now know, those are problematic.
__________________
www.ReTuneTheDeTune.com
2019 M2 Competition (Sunset Orange)
Appreciate 0
      08-29-2017, 11:43 PM   #40
emtkkm8
New Member
2
Rep
22
Posts

Drives: ///M
Join Date: Aug 2017
Location: Cali

iTrader: (0)

how are they holding up?
Appreciate 0
      08-30-2017, 06:34 AM   #41
ChrisK
Major General
ChrisK's Avatar
United_States
3659
Rep
7,216
Posts

Drives: '19 M2C
Join Date: Jun 2007
Location: Chicagoland (West)

iTrader: (6)

Garage List
Quote:
Originally Posted by emtkkm8 View Post
how are they holding up?
Zero issues.
__________________
www.ReTuneTheDeTune.com
2019 M2 Competition (Sunset Orange)
Appreciate 1
      08-30-2017, 09:36 AM   #42
DoZZa
Private First Class
DoZZa's Avatar
United Kingdom
55
Rep
137
Posts

Drives: MY17 | M2 | DCT
Join Date: Jun 2017
Location: UK

iTrader: (0)

I'm afraid I cant recommend SiriusLED. One out of the 10 LED bulbs that they sent me is not the correct type, and another one is faulty.

One of the red brake light LED bulbs is flickering. At first I thought it was down to the coding, but the coding was checked and triple checked, coding is spot on. But still only one of the brake light bulbs would always flicker. I moved the flickering bulb to a different bulb holder in the cluster, but the same bulb still flickered while the others are all fine.

I will say that the bulbs that are working seem to be fairly good quality, but in future I will stick to UK suppliers as I also got hit with a 23.50 customs charge!
__________________
F87 M2 | DCT '17
E46 M3 |SMG '06
E46 M3 | SMG '03
E30 320iS | '90
E28 M535i | '84
Appreciate 1
      08-30-2017, 11:33 AM   #43
ChrisK
Major General
ChrisK's Avatar
United_States
3659
Rep
7,216
Posts

Drives: '19 M2C
Join Date: Jun 2007
Location: Chicagoland (West)

iTrader: (6)

Garage List
Quote:
Originally Posted by DoZZa View Post
I'm afraid I cant recommend SiriusLED. One out of the 10 LED bulbs that they sent me is not the correct type, and another one is faulty.

One of the red brake light LED bulbs is flickering. At first I thought it was down to the coding, but the coding was checked and triple checked, coding is spot on. But still only one of the brake light bulbs would always flicker. I moved the flickering bulb to a different bulb holder in the cluster, but the same bulb still flickered while the others are all fine.

I will say that the bulbs that are working seem to be fairly good quality, but in future I will stick to UK suppliers as I also got hit with a 23.50 customs charge!
Where did you purchase your LED's? Amazon?
__________________
www.ReTuneTheDeTune.com
2019 M2 Competition (Sunset Orange)
Appreciate 0
      08-30-2017, 06:06 PM   #44
DoZZa
Private First Class
DoZZa's Avatar
United Kingdom
55
Rep
137
Posts

Drives: MY17 | M2 | DCT
Join Date: Jun 2017
Location: UK

iTrader: (0)

Quote:
Originally Posted by ChrisK View Post
Where did you purchase your LED's? Amazon?
Direct from SiriusLED website.
__________________
F87 M2 | DCT '17
E46 M3 |SMG '06
E46 M3 | SMG '03
E30 320iS | '90
E28 M535i | '84
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 07:56 PM.




m2
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST