BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
M2 Technical Topics > Navigation, iDrive, Audio, Video, Bluetooth, Phone, Cameras, Electronics > Bimmercode topics

Post Reply
 
Thread Tools Search this Thread
      08-05-2020, 11:37 AM   #2487
Venom
Colonel
Venom's Avatar
United_States
330
Rep
2,393
Posts

Drives: M2 Competition
Join Date: May 2011
Location: East Bay, CA

iTrader: (5)

Garage List
2008 BMW 135i  [4.25]
Quote:
Originally Posted by JDMils View Post
I had a similar issue. After performing a few coding sessions on my car, Bimmercode could not find the dongle (UniCarScan UCSI-2000 Bluetooth). No matter what I tried, could not get the app to find the dongle. The option that worked was to remove the dongle from my Bluetooth settings on my phone and rescan and re-pair and was good then.
Sadly that didn't work for me. Tried 3 dongles and 2 different phones to date and have since given up. May try the old school way in the future when I have more time to code.
Appreciate 0
      08-20-2020, 01:35 PM   #2488
DCrew
New Member
5
Rep
14
Posts

Drives: 2018 M2
Join Date: Jul 2017
Location: Iowa

iTrader: (0)

Good day all. I have a weird coding issue with Bimmercode. I coded my '18 M2 about two years ago with modest changes, such as idrive off when door opened and automatic unlock when ignition switched off. About a month ago the automatic unlock went away for no apparent reason, and although I've tried I can't code it back in. Any theories? My other changes are unaffected.
Appreciate 0
      08-29-2020, 01:59 PM   #2489
Zagnificent55
Private First Class
67
Rep
106
Posts

Drives: 2021 BMW M2C (LBB+6MT+MR)
Join Date: Jun 2020
Location: Austin, TX

iTrader: (0)

Does anyone use the Bimmercode recommended ENET Cable + Ethernet Adapter + Ethernet-->iPhone Lightning adapter? I was reading around the forums elsewhere that this may be a more reliable and stable connection, as well as permit quicker data transmission. Despite being in my early 30s, I try to avoid all the bluetooth and WiFi gadgets and instead stick to hardwired solutions when possible, hence the inclination to the cable. Thoughts? Feedback? Advantages/Disadvantages?
Appreciate 0
      08-29-2020, 02:48 PM   #2490
haagm58
Captain
haagm58's Avatar
United_States
740
Rep
832
Posts

Drives: F30 328d Sport Line
Join Date: Jan 2018
Location: South Carolina

iTrader: (0)

Garage List
Quote:
Originally Posted by Zagnificent55 View Post
Does anyone use the Bimmercode recommended ENET Cable + Ethernet Adapter + Ethernet-->iPhone Lightning adapter? I was reading around the forums elsewhere that this may be a more reliable and stable connection, as well as permit quicker data transmission. Despite being in my early 30s, I try to avoid all the bluetooth and WiFi gadgets and instead stick to hardwired solutions when possible, hence the inclination to the cable. Thoughts? Feedback? Advantages/Disadvantages?
I don't have personal experience using this setup but I've read reviews on the forum and it seems like it's the most reliable method with the fastest data transmission. I've used ENET to laptop and WiFi to iPhone and both work well, but for future coding I'll buy the Ethernet to lightning cable adapter.
Appreciate 0
      08-31-2020, 12:00 AM   #2491
StephGOD
KYHOMPB
StephGOD's Avatar
United_States
128
Rep
230
Posts

Drives: Only BMW's Ja
Join Date: Aug 2014
Location: Bay Area

iTrader: (4)

Garage List
2020 M2C  [0.00]
2017 M3 Comp  [0.00]
2011 135i  [0.00]
Anyone know if it's possible to disable the "adjust sound level based on speed" setting?
Appreciate 0
      09-02-2020, 03:32 PM   #2492
Marlbombs
Private First Class
29
Rep
131
Posts

Drives: 2020 M2C
Join Date: Mar 2015
Location: Florida

iTrader: (0)

Quote:
Originally Posted by doughboy View Post
?? It's a single press to start as standard. Press clutch, press button - it starts.

If you code "turn off idrive when you open the door" it kills everything then you open the door after a single press has stopped the engine.

EDIT - same comments as above....
So I finally decided to code this, and it turns out if you open the door before you turn the ignition off, idrive stays on. That is really stupid. Theres no way to have it turn everything off IF the door is open rather than WHEN?
Appreciate 0
      09-02-2020, 11:42 PM   #2493
mr_lab_rat
Major
mr_lab_rat's Avatar
472
Rep
1,041
Posts

Drives: 2017 M2, 2018 X1
Join Date: Jul 2017
Location: Vancouver

iTrader: (0)

Quote:
Originally Posted by StephGOD View Post
Anyone know if it's possible to disable the "adjust sound level based on speed" setting?
Isn't that possible just through iDrive setting? Or at least minimize the difference between normal and raised when going faster?
Appreciate 0
      09-03-2020, 03:00 PM   #2494
doughboy
Major General
doughboy's Avatar
United Kingdom
946
Rep
8,079
Posts

Drives: 2019 M2 Comp 6MT
Join Date: Jan 2009
Location: UK

iTrader: (2)

Quote:
Originally Posted by StephGOD View Post
Anyone know if it's possible to disable the "adjust sound level based on speed" setting?
Just set it to minimum then it doesn't seem to do anything.
Appreciate 0
      09-03-2020, 03:08 PM   #2495
doughboy
Major General
doughboy's Avatar
United Kingdom
946
Rep
8,079
Posts

Drives: 2019 M2 Comp 6MT
Join Date: Jan 2009
Location: UK

iTrader: (2)

Quote:
Originally Posted by Marlbombs View Post
So I finally decided to code this, and it turns out if you open the door before you turn the ignition off, idrive stays on. That is really stupid. Theres no way to have it turn everything off IF the door is open rather than WHEN?
Not sure its stupid though. Its not just i drive its the whole ignition / dash too of course, like taking the key out of a conventional ignition.

If you want to keep the radio etc on when you turn the engine off and get out then open the door first and it will stay on.

99% of the time you would stop the engine first, then gather your stuff, open the door and the car will shut down.

To me that gives two ways to control the shutdown method.
Appreciate 1
Got f1?238.00

      09-16-2020, 02:10 PM   #2496
Joaco135
Captain
Joaco135's Avatar
United_States
74
Rep
675
Posts

Drives: 2020 M2C LBB
Join Date: Oct 2011
Location: Killeen, TX

iTrader: (4)

Quote:
Originally Posted by m20e3087 View Post
Can we code analog clock display with BimmerCode?
Can this be done on a 2020 M2C?
Appreciate 0
      09-17-2020, 02:22 PM   #2497
dtmurf
Lieutenant
dtmurf's Avatar
250
Rep
505
Posts

Drives: M2
Join Date: Nov 2016
Location: (US M2 in) Belgium

iTrader: (0)

So, I finally gotten around to installing the LCI Tail lights; I've had them sitting in my house for about a year. No problems, everything went smoothly until I want to code. I had faults when I turn on the ignition which I ignored assuming they'd clear when the coding complete and most of them did however, two remain:

Collision Warning System inactive
Pedestrian Warning Malfunction

I've checked the coding and everything is correct but still, these two faults remain.

When I removed the OG tail lights, there were two (2) connectors going to each tail light, the 8 pin connector and a small 2 pin connector with two brown wires. In moving from the 8 pin to the 6 pin connector, I chose to remove the connector completely. I put some heat shrink on each of the two unused Brake wires and taped them back to the cable. I also wrapped the small connector in electrical tape and taped it to the cable. As both of those wires on the small connector are brown, I suspect they are ground wires and I'm wondering if not having this cable connected is causing my problem?
__________________
'17 M2 DCT Long Beach Blue
Appreciate 0
      09-18-2020, 03:10 AM   #2498
Poochie
Luxury at the redline :)
Poochie's Avatar
United_States
5550
Rep
5,927
Posts

Drives: 2016 M2
Join Date: Aug 2012
Location: NYC

iTrader: (2)

Quote:
Originally Posted by dtmurf View Post
So, I finally gotten around to installing the LCI Tail lights; I've had them sitting in my house for about a year. No problems, everything went smoothly until I want to code. I had faults when I turn on the ignition which I ignored assuming they'd clear when the coding complete and most of them did however, two remain:

Collision Warning System inactive
Pedestrian Warning Malfunction

I've checked the coding and everything is correct but still, these two faults remain.

When I removed the OG tail lights, there were two (2) connectors going to each tail light, the 8 pin connector and a small 2 pin connector with two brown wires. In moving from the 8 pin to the 6 pin connector, I chose to remove the connector completely. I put some heat shrink on each of the two unused Brake wires and taped them back to the cable. I also wrapped the small connector in electrical tape and taped it to the cable. As both of those wires on the small connector are brown, I suspect they are ground wires and I'm wondering if not having this cable connected is causing my problem?

My input here:



https://www.bimmerpost.com/forums/sh...php?p=26696753
Appreciate 1
dtmurf250.00

      09-22-2020, 12:12 AM   #2499
blackmist222777
Major
blackmist222777's Avatar
United_States
235
Rep
1,499
Posts

Drives: 2011 BMW 1M
Join Date: Apr 2012
Location: SF Bay Area

iTrader: (12)

Quote:
Originally Posted by haagm58 View Post
BimmerCode has an expert mode which you will probably use because it includes so many additional options that aren't listed in the standard mode.

According to the website I referenced above, Carly is an older platform and was developed for E gen cars and newer, whereas BimmerCode was developed for F series cars and newer.

BimmerCode is very easy to use, since you already have the OBD2 adapter, I'd start there.
This can help too:
__________________

2020 F87 M2C
2011 E82 BMW 1M Series Coupe
Check me out at Point.Shift.Drive (YouTube)
Appreciate 0
      09-27-2020, 10:56 AM   #2500
Flatfoot
New Member
United_States
2
Rep
13
Posts

Drives: 21 M2C
Join Date: Mar 2020
Location: GA

iTrader: (0)

Hello,

Trying to turn off rev-match via :"Start engine without clutch" but I cannot find this under the front module. Car is a 2021 M2C. Thanks!

edit, someone figured it out here: https://f87.bimmerpost.com/forums/sh...8&postcount=37

Thanks!

Last edited by Flatfoot; 09-27-2020 at 11:19 AM..
Appreciate 0
      10-05-2020, 10:44 AM   #2501
Rub1con76
Enlisted Member
32
Rep
34
Posts

Drives: Bmw F87 M2
Join Date: Apr 2018
Location: The Netherlands

iTrader: (0)

Is there a way to code the highlighted strip in bimmercode for an M2?
Attached Images
 
__________________
@Rub1con76
Appreciate 0
      10-06-2020, 03:32 PM   #2502
digimattic
Private
digimattic's Avatar
32
Rep
73
Posts

Drives: 2017 6MT LBB M2
Join Date: Oct 2018
Location: Toronto

iTrader: (0)

So I am pretty sure I have been through each and every one of these pages and not found anything conclusive regarding re-enabling ASD. I had originally coded it off, but have lost my phone and the back up (plus it seems like people are having issues restoring from backups anyway).

The expert settings I have currently coded are:

Model Range: F87
Engine: S55B30 - I have also tried N55
Audio Level: Hifi (0x01)
Power Class: OL (0x03)
Competition Paket: No
Country Variant: US - this is a Canadian car, should I try something different?
Construction Stage: later or equal 07/13 (0x01)
Gear Shifting Sound: No

Still, it shows up as "Unassigned value". Is there any magic setting here? Could someone who has it enabled look at their expert settings and see what the values are?

Thanks all.
Appreciate 0
      10-06-2020, 03:43 PM   #2503
doughboy
Major General
doughboy's Avatar
United Kingdom
946
Rep
8,079
Posts

Drives: 2019 M2 Comp 6MT
Join Date: Jan 2009
Location: UK

iTrader: (2)

Quote:
Originally Posted by Flatfoot View Post
Hello,

Trying to turn off rev-match via :"Start engine without clutch" but I cannot find this under the front module. Car is a 2021 M2C. Thanks!

edit, someone figured it out here: https://f87.bimmerpost.com/forums/sh...8&postcount=37

Thanks!
Cool, but remember this disables all clutch related functions like anti-stall and hill start assist.
Appreciate 0
      10-06-2020, 03:48 PM   #2504
doughboy
Major General
doughboy's Avatar
United Kingdom
946
Rep
8,079
Posts

Drives: 2019 M2 Comp 6MT
Join Date: Jan 2009
Location: UK

iTrader: (2)

Quote:
Originally Posted by digimattic View Post
So I am pretty sure I have been through each and every one of these pages and not found anything conclusive regarding re-enabling ASD. I had originally coded it off, but have lost my phone and the back up (plus it seems like people are having issues restoring from backups anyway).

The expert settings I have currently coded are:

Model Range: F87
Engine: S55B30 - I have also tried N55
Audio Level: Hifi (0x01)
Power Class: OL (0x03)
Competition Paket: No
Country Variant: US - this is a Canadian car, should I try something different?
Construction Stage: later or equal 07/13 (0x01)
Gear Shifting Sound: No

Still, it shows up as "Unassigned value". Is there any magic setting here? Could someone who has it enabled look at their expert settings and see what the values are?

Thanks all.
I had this problem - only then did I read the forum warnings "do not use bimmercode ASD-off feature. Now if I wan't ASD off I just change engine type, that is enough.

Bimmercode backup feature is also garbage. It only goes back one coding step for a start, so if you want to undo something from two or more coding sessions previous - game over.

I had to recode the ASD module with factory parameters using Esys PC coding software.

There are odd settings from factory, I'm working away from home now so can't check them for you i'm afraid.
Appreciate 1
      10-06-2020, 05:03 PM   #2505
digimattic
Private
digimattic's Avatar
32
Rep
73
Posts

Drives: 2017 6MT LBB M2
Join Date: Oct 2018
Location: Toronto

iTrader: (0)

Quote:
Originally Posted by doughboy View Post
I had this problem - only then did I read the forum warnings "do not use bimmercode ASD-off feature. Now if I wan't ASD off I just change engine type, that is enough.

Bimmercode backup feature is also garbage. It only goes back one coding step for a start, so if you want to undo something from two or more coding sessions previous - game over.

I had to recode the ASD module with factory parameters using Esys PC coding software.

There are odd settings from factory, I'm working away from home now so can't check them for you i'm afraid.
I am in the same boat! I'm actually kind of relieved to hear about the backup issue - makes me feel like I would be in the same position regardless of losing the phone.

Where did you get Esys from? Everything I see online makes it seem like you make some donation and email the author ... and hope he responds? Some folks seem to be waiting for months! Seems dodgy.

In any case, I appreciate the response and the input.
Appreciate 0
      10-06-2020, 05:33 PM   #2506
doughboy
Major General
doughboy's Avatar
United Kingdom
946
Rep
8,079
Posts

Drives: 2019 M2 Comp 6MT
Join Date: Jan 2009
Location: UK

iTrader: (2)

Latest Esys was easy to get, but yes the "tokenmaster" code generator, whoever he is, seem to have gone away.

I paid about 10GBP for a key off ebay, worked fine for 2 years now. (had free version for 8 years before that)

example: https://www.ebay.co.uk/itm/BMW-E-SYS...oAAOSwMiFfYQy2
Appreciate 1
      10-07-2020, 08:07 AM   #2507
flybigjet
Remove Before Flight
flybigjet's Avatar
United_States
1855
Rep
887
Posts

Drives: a light twin from Boeing.
Join Date: Dec 2019
Location: Denver, CO

iTrader: (0)

Wait. Hold on. WHAT? You CAN'T encode ASD or undo more than one change?

Um, oops?

I don't have e-Sys, nor the knowledge to do so-- is there any other way to get ASD back to stock? (I was going to recode back to stock, then use the cable).
Appreciate 0
      10-07-2020, 12:46 PM   #2508
digimattic
Private
digimattic's Avatar
32
Rep
73
Posts

Drives: 2017 6MT LBB M2
Join Date: Oct 2018
Location: Toronto

iTrader: (0)

Quote:
Originally Posted by flybigjet View Post
Wait. Hold on. WHAT? You CAN'T encode ASD or undo more than one change?

Um, oops?

I don't have e-Sys, nor the knowledge to do so-- is there any other way to get ASD back to stock? (I was going to recode back to stock, then use the cable).
That seems to be the case. There was an update in the car's software a couple of years ago which appears to prevent fiddling too much with ASD. You used to be able to change the engine sound do all kinds of different models. No longer. Also around this time, people seem to have began fining that they could no longer code ASD back on with Bimmercode. It seems like E-Sys is the only way now - but I would be very glad to be proven wrong on that point since I also lack the software and the knowledge.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 02:50 PM.




m2
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST