BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
M2 Technical Topics > N55 Engine / Drivetrain / Exhaust / Bolt-ons / Tuning > M Performance Exhaust Valve Behavior

Post Reply
 
Thread Tools Search this Thread
      04-09-2019, 02:55 PM   #155
skillz1318
6MT User
56
Rep
62
Posts

Drives: 17 M2 6MT
Join Date: Mar 2016
Location: NoVA

iTrader: (0)

Purchased an M2 via Carmax 2 weeks ago and it already had an MPE installed (wiring as well in trunk), but the bluetooth controller is missing. I think the car sounds great with valves closed, but I was wondering if it's too loud for daily driving when all valves are open?

I don't need to rush out and spend $215 for the bluetooth controller if I will only be opening the valves on weekends/spirited drives.
Appreciate 0
      04-09-2019, 03:16 PM   #156
nothingman
Private NumNuts
nothingman's Avatar
United_States
234
Rep
215
Posts

Drives: 2017 M2 DCT LBB
Join Date: May 2017
Location: Baltimore

iTrader: (0)

Garage List
Quote:
Originally Posted by skillz1318 View Post
... I was wondering if it's too loud for daily driving when all valves are open?

I don't need to rush out and spend $215 for the bluetooth controller if I will only be opening the valves on weekends/spirited drives.
Whether it's too loud for daily driving is subjective, but I can assure you once you've driven the car with the valves open you will be overjoyed with the harmonious melodies of your MPE exhaust.
__________________
Charlie Nibbana
Appreciate 0
      04-09-2019, 03:19 PM   #157
skillz1318
6MT User
56
Rep
62
Posts

Drives: 17 M2 6MT
Join Date: Mar 2016
Location: NoVA

iTrader: (0)

Quote:
Originally Posted by nothingman View Post
Whether it's too loud for daily driving is subjective, but I can assure you once you've driven the car with the valves open you will be overjoyed with the harmonious melodies of your MPE exhaust.
Haha that was my fear/assumption...thanks
Appreciate 0
      04-11-2019, 04:16 PM   #158
gily
Second Lieutenant
gily's Avatar
United_States
85
Rep
275
Posts

Drives: 2018 M2
Join Date: Sep 2015
Location: TX

iTrader: (0)

I just disconnected the harnesses and I have the exhaust flaps open all the time, I had issues that suddenly the flaps would close by itself so I just unplugged the harnesses, I have MPE with Fabspeed sport cat and love the sound, it is not too loud for my liking.
Appreciate 0
      05-17-2019, 10:29 PM   #159
RepLA
New Member
2
Rep
8
Posts

Drives: Alpine White M2
Join Date: Apr 2017
Location: Los Angeles

iTrader: (0)

Does anyone know how to change the battery on this valve control? I know you can just twist it counter clock wise to open it, but I can't see to get the battery out. Any tips?
Appreciate 0
      05-18-2019, 12:55 AM   #160
mr_lab_rat
Captain
mr_lab_rat's Avatar
383
Rep
832
Posts

Drives: 2017 M2, 2018 X1
Join Date: Jul 2017
Location: Vancouver

iTrader: (0)

Quote:
Originally Posted by RepLA View Post
Does anyone know how to change the battery on this valve control? I know you can just twist it counter clock wise to open it, but I can't see to get the battery out. Any tips?
Tweezers or pliers with electrical tape to prevent shorting out.
Appreciate 0
      05-19-2019, 03:05 AM   #161
RepLA
New Member
2
Rep
8
Posts

Drives: Alpine White M2
Join Date: Apr 2017
Location: Los Angeles

iTrader: (0)

Quote:
Originally Posted by mr_lab_rat View Post
Tweezers or pliers with electrical tape to prevent shorting out.

Awesome thank you, not sure why I didn't think of that. Smh

Just pulled it out without electrical tape. Hope I didn't damage it
Appreciate 0
      05-23-2019, 10:54 PM   #162
RepLA
New Member
2
Rep
8
Posts

Drives: Alpine White M2
Join Date: Apr 2017
Location: Los Angeles

iTrader: (0)

So I replaced the battery on the remote, made sure the fuse was tight and made sure the power cable was tight. What else could it be? Could it be a blown out fuse?

Mines opens and within a few minutes it closes ! Gonna contact the dealer tomorrow. Any idea which dealers in Los Angeles will know how to fix this? I know half these bmw dealers are confused when it comes to the technical stuff.
Appreciate 0
      05-24-2019, 12:36 AM   #163
D22M2
Lieutenant
539
Rep
454
Posts

Drives: Not a real M Car
Join Date: Jun 2018
Location: Dublin , CA

iTrader: (0)

Quote:
Originally Posted by RepLA View Post
So I replaced the battery on the remote, made sure the fuse was tight and made sure the power cable was tight. What else could it be? Could it be a blown out fuse?

Mines opens and within a few minutes it closes ! Gonna contact the dealer tomorrow. Any idea which dealers in Los Angeles will know how to fix this? I know half these bmw dealers are confused when it comes to the technical stuff.
I had the same issue and got BMW to replace the controller module + Bluetooth switch

Check out the RA sticker (white sticker) on your module, if itís a 15V Exx or Fxx its no good, a known faulty module. it needs to be a 17V F08 or other module.

Contact Kevin at BMW USA - super nice guy - youíll get squared away in no time

Kevin R. Mulligan
Senior Accessory Development Engineer B2-US-A-23
BMW of North America LLC
200 Chestnut Ridge Road
Woodcliff Lake, NJ 07677
Office: (+1) 201.802.4516
Email: kevin.mulligan@bmwna.com
Appreciate 0
      05-24-2019, 01:18 AM   #164
RepLA
New Member
2
Rep
8
Posts

Drives: Alpine White M2
Join Date: Apr 2017
Location: Los Angeles

iTrader: (0)

Quote:
Originally Posted by D22M2 View Post
I had the same issue and got BMW to replace the controller module + Bluetooth switch

Check out the RA sticker (white sticker) on your module, if itís a 15V Exx or Fxx its no good, a known faulty module. it needs to be a 17V F08 or other module.

Contact Kevin at BMW USA - super nice guy - youíll get squared away in no time

Kevin R. Mulligan
Senior Accessory Development Engineer B2-US-A-23
BMW of North America LLC
200 Chestnut Ridge Road
Woodcliff Lake, NJ 07677
Office: (+1) 201.802.4516
Email: kevin.mulligan@bmwna.com
The white sticker should be on top of it or where exactly?
Awesome thank you! Heís in New Jersey, Iím in Los Angeles, that might be an issue lol
Appreciate 0
      05-24-2019, 01:37 AM   #165
D22M2
Lieutenant
539
Rep
454
Posts

Drives: Not a real M Car
Join Date: Jun 2018
Location: Dublin , CA

iTrader: (0)

Quote:
Originally Posted by RepLA View Post
The white sticker should be on top of it or where exactly?
Awesome thank you! Heís in New Jersey, Iím in Los Angeles, that might be an issue lol
Check out the pic on page 4 - canít miss it

Iím in SF - no issues
Appreciate 0
      05-24-2019, 01:42 AM   #166
RepLA
New Member
2
Rep
8
Posts

Drives: Alpine White M2
Join Date: Apr 2017
Location: Los Angeles

iTrader: (0)

Quote:
Originally Posted by D22M2 View Post
Check out the pic on page 4 - canít miss it

Iím in SF - no issues
How did he go about replacing your unit from New Jersey?
Appreciate 0
      05-24-2019, 01:44 AM   #167
D22M2
Lieutenant
539
Rep
454
Posts

Drives: Not a real M Car
Join Date: Jun 2018
Location: Dublin , CA

iTrader: (0)

Quote:
Originally Posted by RepLA View Post
How did he go about replacing your unit from New Jersey?
They sent the replacement units to my local BMW dealer - free of chargeÖ All under warranty
Appreciate 0
      05-24-2019, 02:16 AM   #168
RepLA
New Member
2
Rep
8
Posts

Drives: Alpine White M2
Join Date: Apr 2017
Location: Los Angeles

iTrader: (0)

Quote:
Originally Posted by D22M2 View Post
They sent the replacement units to my local BMW dealer - free of chargeÖ All under warranty
oh nice! I just emailed him, I hope he can help!
Thanks for the advice, I appreciate it.
Appreciate 0
      08-26-2019, 02:18 AM   #169
coldM2
Private First Class
43
Rep
117
Posts

Drives: Bmw340iMPPSK/BmwM2MPE
Join Date: Jul 2018
Location: Sweden

iTrader: (0)

BMW M2 MPE bluetooth issue

Ive had my M2 with MPE for a couple of months right now and one thing thats really bothering me is that it shuts itself of (closes the valves) by itself very frequently. Sometimes I open the valves and it shuts them after 5 seconds, but other times it can stay open for several minutes or even longer (15-20min). I dont know what causes this issue but its really starting to bother me. Ive heard that it can miscommunicate with my phone bluetooth but that doesnt seem right. Anyone with an MPE exhaust with the bluetooth button that has the same issue and has found a way to work around it? Thanks in advance.
Appreciate 0
      08-26-2019, 08:40 PM   #170
SeanWRT
Colonel
SeanWRT's Avatar
2512
Rep
2,292
Posts

Drives: E90 M3 & F87 M2
Join Date: Sep 2015
Location: Shanghai

iTrader: (1)

Had same issue. It closes on its own very frequently in heavy traffic, but keeps open fine when being away from downtown city.

First thought it's the blue tooth interference or the fuse in the trunk, it was not. Turned out to be the faulty BT module. Bought a new module from local dealer (no warranty coverage because I bought MPE from oversea) and problem fixed.
__________________
Lemania 2320
Appreciate 0
      08-26-2019, 10:17 PM   #171
wanofakind01
Lieutenant
246
Rep
575
Posts

Drives: '17 BMW M2 6MT, '16 BMW X1
Join Date: Jun 2015
Location: DC

iTrader: (3)

Quote:
Originally Posted by SeanWRT View Post
Had same issue. It closes on its own very frequently in heavy traffic, but keeps open fine when being away from downtown city.

First thought it's the blue tooth interference or the fuse in the trunk, it was not. Turned out to be the faulty BT module. Bought a new module from local dealer (no warranty coverage because I bought MPE from oversea) and problem fixed.
How much did that cost you?
Appreciate 0
      08-26-2019, 11:40 PM   #172
SeanWRT
Colonel
SeanWRT's Avatar
2512
Rep
2,292
Posts

Drives: E90 M3 & F87 M2
Join Date: Sep 2015
Location: Shanghai

iTrader: (1)

Quote:
Originally Posted by wanofakind01 View Post
Quote:
Originally Posted by SeanWRT View Post
Had same issue. It closes on its own very frequently in heavy traffic, but keeps open fine when being away from downtown city.

First thought it's the blue tooth interference or the fuse in the trunk, it was not. Turned out to be the faulty BT module. Bought a new module from local dealer (no warranty coverage because I bought MPE from oversea) and problem fixed.
How much did that cost you?
Equal to about 400-450 USD but keep in mind auto part price in my market hugely inflate like the car.

I was also told bmw normally doesn't sell module separately and there's no part # for it.
__________________
Lemania 2320
Appreciate 0
      08-27-2019, 12:44 AM   #173
coldM2
Private First Class
43
Rep
117
Posts

Drives: Bmw340iMPPSK/BmwM2MPE
Join Date: Jul 2018
Location: Sweden

iTrader: (0)

Quote:
Originally Posted by SeanWRT View Post
Equal to about 400-450 USD but keep in mind auto part price in my market hugely inflate like the car.

I was also told bmw normally doesn't sell module separately and there's no part # for it.
Dont sell the module separately? What if you manage to lose it or break it
I bought my car secondhand and it had the mpe from BMW so I dont know if theres any coverage for a replacement module. Its just a very weird issue...
Appreciate 0
      08-27-2019, 01:13 AM   #174
KO7
Private
39
Rep
77
Posts

Drives: 2017 BMW M2
Join Date: Dec 2014
Location: Canada

iTrader: (0)

I've had my M2 with MPE for about 6 months now and I've noticed the same issue with the valves closing automatically in heavier traffic. I'll ask for a possible warranty fix next time I'm in for an oil change.
Appreciate 0
      08-27-2019, 03:21 AM   #175
F87 M2CS
Second Lieutenant
F87 M2CS's Avatar
Cyprus
149
Rep
208
Posts

Drives: F87 M2CS 6MT (waiting list)
Join Date: Jan 2018
Location: Nicosia

iTrader: (0)

Quote:
Originally Posted by coldM2 View Post
Ive had my M2 with MPE for a couple of months right now and one thing thats really bothering me is that it shuts itself of (closes the valves) by itself very frequently. Sometimes I open the valves and it shuts them after 5 seconds, but other times it can stay open for several minutes or even longer (15-20min). I dont know what causes this issue but its really starting to bother me. Ive heard that it can miscommunicate with my phone bluetooth but that doesnt seem right. Anyone with an MPE exhaust with the bluetooth button that has the same issue and has found a way to work around it? Thanks in advance.
Never happened to me , the only thing happened tho with bluetooth is from the iphone to the media which is again connected with bluetooth. It loses its connection after 2-3 minutes and i have to do the same process from the beginning. Maybe that issue have something to do with yours
Appreciate 0
      08-27-2019, 03:41 AM   #176
GoneIn4Secs
Major
GoneIn4Secs's Avatar
Canada
663
Rep
1,142
Posts

Drives: '18 M2
Join Date: Jun 2018
Location: gta Canada

iTrader: (0)

The only time this had happened to me in the past is when i would open up the valves beforr i had started thr car (to hear the big cold rumble startup), i noticed it would shut off after a few mins i got rolling

However, once i started opening up the valves after i had started rolling, ie in drive already, it never happens
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 02:54 PM.




m2
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST