BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
M2 Technical Topics > Track / Autocross / Dragstrip > Anyone has a performance steering wheel running data acquisition?

Post Reply
 
Thread Tools Search this Thread
      09-02-2020, 05:10 PM   #1
imolam3
Private First Class
37
Rep
117
Posts

Drives: 2004 Imola M3, 2017 AW M2 PE
Join Date: Jul 2011
Location: San Antonio, Texas

iTrader: (0)

Anyone has a performance steering wheel running data acquisition?

Hi all,

From speaking with Tom at EAS Tuning in CA, the vehicle can only use 1 CAN address to send data, my problem is that I have the BMW performance steering wheel with the electronic display which also pulled signal from the CAN. Tom indicated that running both the Racelogic data acquisition system and the steering wheel at the same time is not possible.

Anyone with the same steering wheel/data acq. system running into the same issue? I guess I can power off the steering wheel and use the Racelogic at the track then turn off the RL and power on the wheel for the street....

Thoughts?
__________________
1997 Dakar M3
1999 Cosmos M3
2004 Imola M3 CSL clone
2017 Alpine White M2 Performance Edition
Appreciate 0
      09-02-2020, 05:26 PM   #2
detroitm2
Lieutenant Colonel
detroitm2's Avatar
United_States
1711
Rep
1,957
Posts

Drives: 2018 M2
Join Date: Aug 2018
Location: Michigan

iTrader: (1)

Garage List
2018 BMW M2  [0.00]
Quote:
Originally Posted by imolam3 View Post
Hi all,

From speaking with Tom at EAS Tuning in CA, the vehicle can only use 1 CAN address to send data, my problem is that I have the BMW performance steering wheel with the electronic display which also pulled signal from the CAN. Tom indicated that running both the Racelogic data acquisition system and the steering wheel at the same time is not possible.

Anyone with the same steering wheel/data acq. system running into the same issue? I guess I can power off the steering wheel and use the Racelogic at the track then turn off the RL and power on the wheel for the street....

Thoughts?
This seems odd to me. From what I understand, data loggers just "sniff" traffic on the canbus. The data isn't being sent directly to it.

If the t was the cases, everything that relies on the canbus in your car would fail to work the second you tapped a data logger into it.

I run an aim solo 2 dl on the track that I have tapped directly into the canbus from the FEM in the passenger footwell. Don't have a performance steering wheel, but again, I don't see why this would be a problem short of the network not being able to handle the additional bandwidth.

Honestly don't know enough about it to be sure. I guess I could plug another data logger (Bluetooth to Harry's laptimer for example) into my OBD port and see what happens.
Appreciate 0
      09-02-2020, 05:35 PM   #3
imolam3
Private First Class
37
Rep
117
Posts

Drives: 2004 Imola M3, 2017 AW M2 PE
Join Date: Jul 2011
Location: San Antonio, Texas

iTrader: (0)

I was told the vehicle only has 1 CAN address and can't be sending data to 2 different sources. I believe Tom said the same issue came up with JB4 installed and running AWRON at the same time.

Can you connect to the OBD2 port with a device power on and see if your AIM Solo is running normally while driving?

Quote:
Originally Posted by detroitm2 View Post
This seems odd to me. From what I understand, data loggers just "sniff" traffic on the canbus. The data isn't being sent directly to it.

If the t was the cases, everything that relies on the canbus in your car would fail to work the second you tapped a data logger into it.

I run an aim solo 2 dl on the track that I have tapped directly into the canbus from the FEM in the passenger footwell. Don't have a performance steering wheel, but again, I don't see why this would be a problem short of the network not being able to handle the additional bandwidth.

Honestly don't know enough about it to be sure. I guess I could plug another data logger (Bluetooth to Harry's laptimer for example) into my OBD port and see what happens.
__________________
1997 Dakar M3
1999 Cosmos M3
2004 Imola M3 CSL clone
2017 Alpine White M2 Performance Edition
Appreciate 0
      09-02-2020, 05:36 PM   #4
detroitm2
Lieutenant Colonel
detroitm2's Avatar
United_States
1711
Rep
1,957
Posts

Drives: 2018 M2
Join Date: Aug 2018
Location: Michigan

iTrader: (1)

Garage List
2018 BMW M2  [0.00]
Quote:
Originally Posted by imolam3 View Post
I was told the vehicle only has 1 CAN address and can't be sending data to 2 different sources. I believe Tom said the same issue came up with JB4 installed and running AWRON at the same time.

Can you connect to the OBD2 port with a device power on and see if your AIM Solo is running normally while driving?

Quote:
Originally Posted by detroitm2 View Post
This seems odd to me. From what I understand, data loggers just "sniff" traffic on the canbus. The data isn't being sent directly to it.

If the t was the cases, everything that relies on the canbus in your car would fail to work the second you tapped a data logger into it.

I run an aim solo 2 dl on the track that I have tapped directly into the canbus from the FEM in the passenger footwell. Don't have a performance steering wheel, but again, I don't see why this would be a problem short of the network not being able to handle the additional bandwidth.

Honestly don't know enough about it to be sure. I guess I could plug another data logger (Bluetooth to Harry's laptimer for example) into my OBD port and see what happens.
Yeah, I'll give it a shot this evening and see what happens.
Appreciate 0
      09-02-2020, 08:53 PM   #5
detroitm2
Lieutenant Colonel
detroitm2's Avatar
United_States
1711
Rep
1,957
Posts

Drives: 2018 M2
Join Date: Aug 2018
Location: Michigan

iTrader: (1)

Garage List
2018 BMW M2  [0.00]
Quote:
Originally Posted by imolam3 View Post
I was told the vehicle only has 1 CAN address and can't be sending data to 2 different sources. I believe Tom said the same issue came up with JB4 installed and running AWRON at the same time.

Can you connect to the OBD2 port with a device power on and see if your AIM Solo is running normally while driving?

Quote:
Originally Posted by detroitm2 View Post
This seems odd to me. From what I understand, data loggers just "sniff" traffic on the canbus. The data isn't being sent directly to it.

If the t was the cases, everything that relies on the canbus in your car would fail to work the second you tapped a data logger into it.

I run an aim solo 2 dl on the track that I have tapped directly into the canbus from the FEM in the passenger footwell. Don't have a performance steering wheel, but again, I don't see why this would be a problem short of the network not being able to handle the additional bandwidth.

Honestly don't know enough about it to be sure. I guess I could plug another data logger (Bluetooth to Harry's laptimer for example) into my OBD port and see what happens.
So I connected a VEEPEAK Bluetooth obd adapter, linked to track addict on my phone. Started the car up, everything was fine. It was reading data (RPM, etc). I connected my aim solo 2 dl, and that was also recording data just fine. I turned the car off and started back up with both connected, was showing Sara on both devices.

Now maybe the OBD port has a separate bus that it works off of, I know when I bought my solo, they told me that more data was available if I went straight to the canbus vs. plugging into the OBD port (different cable for each).

Like I said before, I would think that it should work.

Last edited by detroitm2; 09-03-2020 at 08:53 AM..
Appreciate 0
      09-03-2020, 08:28 AM   #6
imolam3
Private First Class
37
Rep
117
Posts

Drives: 2004 Imola M3, 2017 AW M2 PE
Join Date: Jul 2011
Location: San Antonio, Texas

iTrader: (0)

Thanks for checking. I'll power up the RL and steering wheel today and see what'll happen.
__________________
1997 Dakar M3
1999 Cosmos M3
2004 Imola M3 CSL clone
2017 Alpine White M2 Performance Edition
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 06:30 PM.




m2
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST