BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW M2 Forum > BMW M2 Discussions > I heard the M2 is quite reliable. True ?

Post Reply
 
Thread Tools Search this Thread
      02-03-2020, 04:57 PM   #23
F87source
Major
F87source's Avatar
Canada
484
Rep
1,169
Posts

Drives: 2017 Bmw M2 6mt
Join Date: Aug 2018
Location: Canada

iTrader: (0)

Quote:
Originally Posted by tranck View Post
It's ~1K just for the flywheel - already checked. At 55K miles, my SA said that if you replace the clutch, you should also replace the flywheel at that mileage.
Aftermarket solutions are $1k for both, you likely can just resurface the flywheel and just get a new clutch.
__________________
Follow me on Instagram @f87source
Appreciate 2
tranck446.50

      02-03-2020, 05:18 PM   #24
VisualEcho
Major
VisualEcho's Avatar
United_States
1454
Rep
1,123
Posts

Drives: 2018 BMW M2
Join Date: Sep 2019
Location: Missouri

iTrader: (0)

Garage List
2018 BMW M2  [0.00]
Quote:
Originally Posted by F87source View Post
Aftermarket solutions are $1k for both, you likely can just resurface the flywheel and just get a new clutch.
I'm wondering when they should really be done. I don't drive my car hard at all, and if I need a clutch/flywheel assy at 55K miles I'm going to raise hell.
__________________
2006 Lotus Exige | 2018 M2
Appreciate 0
      02-03-2020, 05:51 PM   #25
Mosely
Lieutenant
Mosely's Avatar
458
Rep
439
Posts

Drives: '18 M2 | '20 X5 | '07 E92
Join Date: Mar 2017
Location: SoCal

iTrader: (0)

Quote:
Originally Posted by VisualEcho View Post
I'm wondering when they should really be done. I don't drive my car hard at all, and if I need a clutch/flywheel assy at 55K miles I'm going to raise hell.
Yeah that would be ridiculous. I also have a 07 328i with 140k miles on stock clutch, still holding strong.
__________________
IG Photo Gallery:
instagram.com/dr_m2sko/

Appreciate 3
Moflow870.00
VisualEcho1453.50

      02-03-2020, 05:58 PM   #26
F87source
Major
F87source's Avatar
Canada
484
Rep
1,169
Posts

Drives: 2017 Bmw M2 6mt
Join Date: Aug 2018
Location: Canada

iTrader: (0)

Quote:
Originally Posted by VisualEcho View Post
I'm wondering when they should really be done. I don't drive my car hard at all, and if I need a clutch/flywheel assy at 55K miles I'm going to raise hell.
It should last well into 100k miles, depending on driving habits etc.
__________________
Follow me on Instagram @f87source
Appreciate 2
Moflow870.00
VisualEcho1453.50

      02-03-2020, 08:32 PM   #27
VisualEcho
Major
VisualEcho's Avatar
United_States
1454
Rep
1,123
Posts

Drives: 2018 BMW M2
Join Date: Sep 2019
Location: Missouri

iTrader: (0)

Garage List
2018 BMW M2  [0.00]
I mean, I'll be the first person to admit that I don't drive the car as intended, and would have been better served with a 235 or less, but I just love the styling, so here I am. Also, I have an Exige for performance duty. Having said that, I hope to get 100,000 trouble-free miles out of this car for the way it is treated.
__________________
2006 Lotus Exige | 2018 M2
Appreciate 1
      02-03-2020, 08:38 PM   #28
F87source
Major
F87source's Avatar
Canada
484
Rep
1,169
Posts

Drives: 2017 Bmw M2 6mt
Join Date: Aug 2018
Location: Canada

iTrader: (0)

Quote:
Originally Posted by VisualEcho View Post
I mean, I'll be the first person to admit that I don't drive the car as intended, and would have been better served with a 235 or less, but I just love the styling, so here I am. Also, I have an Exige for performance duty. Having said that, I hope to get 100,000 trouble-free miles out of this car for the way it is treated.
You'll likely get 100k miles without any clutch issues.
__________________
Follow me on Instagram @f87source
Appreciate 0
      02-04-2020, 02:38 AM   #29
tranck
First Lieutenant
tranck's Avatar
447
Rep
307
Posts

Drives: 2018 Alpine White BMW M2
Join Date: May 2018
Location: Aberdeen, NC

iTrader: (0)

Garage List
2018 M2  [0.00]
Quote:
Originally Posted by F87source View Post
You'll likely get 100k miles without any clutch issues.
https://f87.bimmerpost.com/forums/sh....php?t=1456330

Last edited by tranck; 02-04-2020 at 02:44 AM..
Appreciate 0
      02-04-2020, 09:00 AM   #30
VisualEcho
Major
VisualEcho's Avatar
United_States
1454
Rep
1,123
Posts

Drives: 2018 BMW M2
Join Date: Sep 2019
Location: Missouri

iTrader: (0)

Garage List
2018 BMW M2  [0.00]
Quote:
Originally Posted by tranck View Post
Seems like a small sample. Hopefully I'll get lucky, no issues so far at 12K miles.
__________________
2006 Lotus Exige | 2018 M2
Appreciate 0
      02-04-2020, 12:07 PM   #31
AlpsRider
Colonel
AlpsRider's Avatar
1769
Rep
2,731
Posts

Drives: M2 Competition, LBB, 6MT
Join Date: May 2015
Location: Earth

iTrader: (0)

I've never had to replace a clutch. I had an Audi Coupe that had the 5 banger with 140,000 miles, the clutch still worked but got a bit chattery on occasion. I don't ride the clutch peddle so throw out bearings always last.
Appreciate 0
      02-04-2020, 12:27 PM   #32
mr_lab_rat
Captain
mr_lab_rat's Avatar
399
Rep
893
Posts

Drives: 2017 M2, 2018 X1
Join Date: Jul 2017
Location: Vancouver

iTrader: (0)

Quote:
Originally Posted by F87source View Post
A resistance in shifting from 1st to 2nd, but no gear grinding or any real issues.
I struggle with 1-2 upshift under hard acceleration while turning left. I assume it's the engine and transmission mounts flexing. One of these days I'll experiment with stiffer mounts. I know I'm definitely gonna start with the front shifter bushing and take it from there.
Appreciate 0
      02-04-2020, 01:07 PM   #33
F87source
Major
F87source's Avatar
Canada
484
Rep
1,169
Posts

Drives: 2017 Bmw M2 6mt
Join Date: Aug 2018
Location: Canada

iTrader: (0)

Quote:
Originally Posted by mr_lab_rat View Post
I struggle with 1-2 upshift under hard acceleration while turning left. I assume it's the engine and transmission mounts flexing. One of these days I'll experiment with stiffer mounts. I know I'm definitely gonna start with the front shifter bushing and take it from there.
Yeah it could definitely be that, hmm I'll probably look into mounts too. Engine mounts when I install the turbo, and transmission mounts with my ask.
__________________
Follow me on Instagram @f87source
Appreciate 0
      02-04-2020, 11:23 PM   #34
bluem2
Private
13
Rep
68
Posts

Drives: lbb m2
Join Date: Jan 2018
Location: asia

iTrader: (0)

I had the charge pipe crack just recently after 2 years of ownership, nothing else of major concern though. No one else has faulty charge pipes ?!!
Appreciate 0
      02-05-2020, 02:28 AM   #35
F87source
Major
F87source's Avatar
Canada
484
Rep
1,169
Posts

Drives: 2017 Bmw M2 6mt
Join Date: Aug 2018
Location: Canada

iTrader: (0)

Quote:
Originally Posted by bluem2 View Post
I had the charge pipe crack just recently after 2 years of ownership, nothing else of major concern though. No one else has faulty charge pipes ?!!
Very common issue nothing to be worried about.

Not yet fortunately, on my m235i yes, but not yet on my m2.
__________________
Follow me on Instagram @f87source
Appreciate 0
      02-05-2020, 12:02 PM   #36
AlpsRider
Colonel
AlpsRider's Avatar
1769
Rep
2,731
Posts

Drives: M2 Competition, LBB, 6MT
Join Date: May 2015
Location: Earth

iTrader: (0)

Quote:
Originally Posted by F87source View Post
Very common issue nothing to be worried about.

Not yet fortunately, on my m235i yes, but not yet on my m2.
Many people seem to jump the gun and change out their charge pipes. I would never do that until the warranty was up. I mean its not a dangerous thing.
Appreciate 0
      02-05-2020, 12:02 PM   #37
dtmurf
Lieutenant
dtmurf's Avatar
213
Rep
451
Posts

Drives: M2
Join Date: Nov 2016
Location: (US M2 in) Belgium

iTrader: (0)

Mine's a late May/early Jun 2017 build. Picked it up at the end of July and have had zero (0) problems so far and let hope it stays that way!

I am planning to swap out the charge pipe soon just in case.
__________________
'17 M2 DCT Long Beach Blue
Appreciate 0
      02-05-2020, 12:14 PM   #38
VisualEcho
Major
VisualEcho's Avatar
United_States
1454
Rep
1,123
Posts

Drives: 2018 BMW M2
Join Date: Sep 2019
Location: Missouri

iTrader: (0)

Garage List
2018 BMW M2  [0.00]
Quote:
Originally Posted by AlpsRider View Post
Many people seem to jump the gun and change out their charge pipes. I would never do that until the warranty was up. I mean its not a dangerous thing.
The car just runs rough? No codes?
__________________
2006 Lotus Exige | 2018 M2
Appreciate 0
      02-05-2020, 12:14 PM   #39
Al Bundy's Dodge
Second Lieutenant
228
Rep
257
Posts

Drives: 2015 335i xDrive
Join Date: Jan 2018
Location: Denver

iTrader: (0)

Quote:
Originally Posted by tranck View Post

FWIW, I had a similar shudder issue in my current 2015 335i when trying to engage 1st gear. I had to give it a ton of throttle to avoid the shudder. light throttle the shudder was bad. developed around 35k miles.

When I took it to the dealer they found SIB 120915, specific to the N55. From what I recall it was a software issue. Fixed the issue immediately. Came back a year later...i wonder if when I had it in the dealer for another reason, they reset the software an wiped out the fix. When I took it back and pointed them to SIB 120915, it fixed the issue again.

Quote:
TSB #120915
NHTSA ID #10147599
JANUARY 01 2015
Additional Info:
How to Fix
Summary: "SUBJECT N55: Slight Surging at Constant Speeds when Accelerating Very Lightly. The vehicle shudders or surges slightly while driving at constant speeds and applying the accelerator very lightly. This symptom is most easily reproduced under...
__________________
2015 335i xDrive 6MT - Melbourne Red - M Sport - DHP - Cold Weather Pkg - Light Package - and a buncha other stuff I dont use
2018 M2 6MT - Black Sapphire Metallic - Executive Pkg
Appreciate 2
tranck446.50
VisualEcho1453.50

      02-05-2020, 12:15 PM   #40
F87source
Major
F87source's Avatar
Canada
484
Rep
1,169
Posts

Drives: 2017 Bmw M2 6mt
Join Date: Aug 2018
Location: Canada

iTrader: (0)

Quote:
Originally Posted by AlpsRider View Post
Many people seem to jump the gun and change out their charge pipes. I would never do that until the warranty was up. I mean its not a dangerous thing.
It's a good idea to change if you can't afford any down time on your car. There's a small chance that when the charge pipe blows it'll send small plastic fragments into the motor which can cause engine failure. However if it's still under warranty I'd say just leave it stock, if it fails get a new charge pipe from the dealership, if the motor goes get a new motor. Me personally there are better things to spend money to mod like an ssk for instance.
__________________
Follow me on Instagram @f87source
Appreciate 0
      02-05-2020, 02:43 PM   #41
Tano
First Lieutenant
Tano's Avatar
Hungary
274
Rep
351
Posts

Drives: BMW M2
Join Date: Oct 2015
Location: Hungary

iTrader: (0)

After 2,5 years my Idrive started to go nuts. It restarts every couple of minutes, it must be changed if reprogramming doesn't solve the issue.
And the amplifier in the boot can get wet and will die, so should install splash guard in cars made before spring 2019
__________________
Appreciate 0
      02-05-2020, 02:49 PM   #42
VisualEcho
Major
VisualEcho's Avatar
United_States
1454
Rep
1,123
Posts

Drives: 2018 BMW M2
Join Date: Sep 2019
Location: Missouri

iTrader: (0)

Garage List
2018 BMW M2  [0.00]
Quote:
Originally Posted by Tano View Post
And the amplifier in the boot can get wet and will die, so should install splash guard in cars made before spring 2019
How does the amp get wet?
__________________
2006 Lotus Exige | 2018 M2
Appreciate 0
      02-05-2020, 03:21 PM   #43
Mosely
Lieutenant
Mosely's Avatar
458
Rep
439
Posts

Drives: '18 M2 | '20 X5 | '07 E92
Join Date: Mar 2017
Location: SoCal

iTrader: (0)

Quote:
Originally Posted by VisualEcho View Post
How does the amp get wet?
Most people had it happen while getting tint done if I recall
Appreciate 0
      02-05-2020, 03:34 PM   #44
Altra
Second Lieutenant
183
Rep
228
Posts

Drives: 2016 AW M2
Join Date: Jun 2018
Location: Orange County

iTrader: (0)

Quote:
Originally Posted by VisualEcho View Post
The car just runs rough? No codes?
I had an aftermarket charge pipe pop off on me cuz I didn't tighten one of the clamps that connects the upper & lower pipe together tight enough.
Instant loss of boost, revs climbed but zero power, followed by a CEL on restart.
Appreciate 1
VisualEcho1453.50

Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 01:21 AM.




m2
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST